POJ 1013题解

 

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars ; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars . The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins . 
Happily, Sally has a friend who loans her a very accurate balance scale . The friend will permit Sally three weighings to find the counterfeit coin . For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true . Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down , respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings .

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars ; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars . The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins . 
Happily, Sally has a friend who loans her a very accurate balance scale . The friend will permit Sally three weighings to find the counterfeit coin . For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true . Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down , respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings .

 

Input

The first line of input is an integer n (n> 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A - L. Information on a weighing will be given by two strings of letters and then one of the words `` up '', `` down '', or `` even ''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input


ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

 

 大致题意:Sally有12枚硬币,标号为A-L,其中有1枚假币,另外11枚为真币,假币可能比真币重也可能比真币轻,现在利用天平进行3次测量,根据测量结果判断哪枚是假币。

思路:因为只有一枚是假币,可以通过每一次测量进行猜想两边硬币的情况(如ABCI  EFJK  up,可以猜想 A,B,C,I重量为2,E,F,J,K重量为1 ),经过3次猜想后,3次猜想不变的那枚硬币则为假币。(这里好像跟警察猜罪犯一样,满足所有假设的自然为罪犯)。

这里声明:这是本人第一次写博客,请多多指教。

 

 

下面为代码:

#include<iostream>
#include<cstring>
using namespace std;
#define ll long long 
int book[200];
int w[200];
int main(){
	ios::sync_with_stdio(false);
	cin.tie(0);
    int T;
    cin>>T;
    while(T--){
    	memset(book,-1,sizeof(book));
    	memset(w,0,sizeof(w));
    	string a[4],b[4],c[4];
    	for(register int i=0;i<3;i++){
    		cin>>a[i]>>b[i]>>c[i];
    	}
    	for(register int i=0;i<3;i++){
    		for(register int j=0;j<a[i].size();j++){
    			if(c[i]=="even"){
    				if(book[a[i][j]]==-1)
    				book[a[i][j]]=0;
    				else if(book[a[i][j]]!=-1&&book[a[i][j]]!=0){
    					w[a[i][j]]++;
    					book[a[i][j]]=0;
    				}
    			}
    			else if(c[i]=="up"){
    				if(book[a[i][j]]==-1)
    				book[a[i][j]]=2;
    				else if(book[a[i][j]]!=2){
    					w[a[i][j]]++;
    					book[a[i][j]]=2;
					}
				}
				else if(c[i]=="down"){
					if(book[a[i][j]]==-1)
					  book[a[i][j]]=1;
					  else if(book[a[i][j]]!=1){
					  	w[a[i][j]]++;
					  	book[a[i][j]]=1;
					  }
				}
    		}
    		for(register int j=0;j<b[i].size();j++){
    			if(c[i]=="even"){
    				if(book[b[i][j]]==-1){
    				book[b[i][j]]=0;
				   }
				   else if(book[b[i][j]]!=0){
				   	w[b[i][j]]++;
				   	book[b[i][j]]=0;
				   }
				}
				else if(c[i]=="up"){
					if(book[b[i][j]]==-1)
					book[b[i][j]]=1;
					else if(book[b[i][j]]!=1){
						w[b[i][j]]++;
						book[b[i][j]]=1;
					}
				}
				else if(c[i]=="down"){
					if(book[b[i][j]]==-1)
					book[b[i][j]]=2;
					else if(book[b[i][j]]!=2){
						w[b[i][j]]++;
						book[b[i][j]]=2;
					}
				}
				
			}
    	}
    	int t;
    	for(register int i=0;i<3;i++){
    		if(c[i]!="even")
    		t=i;
		}
		int flag=0;
	    for(register int i=0;i<a[t].size();i++){
	    	if(!w[a[t][i]]){
	    		if(c[t]=="up"){
	    			cout<<a[t][i]<<" is the counterfeit coin and it is heavy."<<endl;
				}
				else if(c[t]=="down")
				cout<<a[t][i]<<" is the counterfeit coin and it is light."<<endl;
				flag=1;
				break;
			} 
		}
		if(flag)continue;
		for(register int i=0;i<b[t].size();i++){
			if(!w[b[t][i]]){
				if(c[t]=="up")
				cout<<b[t][i]<<" is the counterfeit coin and it is light."<<endl;
				else if(c[t]=="down")
				cout<<b[t][i]<<" is the counterfeit coin and it is heavy."<<endl;
				break;
			}
		}
    }
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值