天梯赛——玩转二叉树 (25 分)

传送门

给定一棵二叉树中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

CODE:

#include<bits/stdc++.h>
using namespace std;
#define N 50
#include<queue>
queue<int>qu;
int f[N],m[N];
struct node
{
	int l,r;
}q[N];
int root;
int build(int la,int ra,int lb,int rb)//mid  first
{
	if(la>ra)
	return 0;
	int i=0;
	int rt=f[lb];///find root
	while(m[i]!=rt)
	i++;
	q[rt].l=build(la,i-1,lb+1,lb+i-la);///left
	q[rt].r=build(i+1,ra,lb+i-la+1,rb);///right
	return rt;
}
void dfs(int root)
{
	if(q[root].l==q[root].r&&q[root].l==0)
	return ;
	else
	{
		swap(q[root].l,q[root].r);///swap
		dfs(q[root].l);
		dfs(q[root].r);
	}
}
void bfs(int root)
{
	int flag=0;
	qu.push(root);
	while(!qu.empty())
	{
		int x=qu.front();
		qu.pop();
		if(!flag)
		flag=1,cout<<x;
		else cout<<" "<<x;
		if(q[x].l!=0)///exist->input queue 
		qu.push(q[x].l);
		if(q[x].r!=0)
		qu.push(q[x].r);
	}
	cout<<endl;
}
int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		cin>>m[i];
	}
	for(int i=1;i<=n;i++)
	{
		cin>>f[i];
	}
	root=build(1,n,1,n);
	dfs(root);///swap
	bfs(root);///input
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值