A Mini Locomotive---小型机车

http://poj.org/problem?id=1976

 

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows: 

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives. 
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches. 
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1. 

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60. 

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers. 

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives. 

Input

The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches. 

Output

There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input

1
7
35 40 50 10 30 45 60
2

Sample Output

240

 题意:

三个车头,然后是n节车厢,以及每节车厢的乘客数,m表示每个车头所能拉的车厢数,车头所拉车厢必须是连续的,问所能拉的最大乘客数。

思路:

 一个数列,n个数,找三个m个连续数的子数列,使其和最大。

因为m<=N/3, 所以按照贪心的思想,为了拉更多的人,每个火车头一定是要拉m个连续的车厢

然后,为了求某段连续的车厢共有多少人,可以前缀和预处理, 某一段和=sum[ i ] - sum[ i-m].

f[i][j] 代表前i个车厢,用j个火车头拉,最多能拉多少人。

对于第i个车厢,如果当前这个车头选择要拉这个车厢,那么要把以i为最后一个车厢的连续m个车厢一起拉,所以状态转移方程是
 dp[i-m][j-1]+(sum[i]-sum[i-m])

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int sum[50050],a[50050];
int dp[50050][4];///前i节车厢用j个火车头拉   
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(sum,0,sizeof(sum));
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        int n,m;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum[i]=sum[i-1]+a[i];///前i节车厢人数
        }
        scanf("%d",&m);
        for(int i=m;i<=n;i++)    
        {
            for(int j=3;j>=1;j--)
            {///每种状态面临两种取法 取或者不取 以第i节车厢为首的m节车厢
                dp[i][j]=max(dp[i-1][j],dp[i-m][j-1]+(sum[i]-sum[i-m]));
            }///不选    选
        }
        printf("%d\n",dp[n][3]);
    }
    return 0;
}

 

既然选择了远方,便只顾风雨兼程!~

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值