Is It A Tree?(它是一棵树吗?)

Is It A Tree? - POJ 1308 - Virtual Judge

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

 题意:给出若干对数字,前一个为后一个的父节点,结合所有给出的情况 判断其是否组成一棵树。

思路:用并查集来实现,结合树的定义规则;

我是看这个代码,才理解这个题的!O(∩_∩)O谢谢

判断有向图是否为有向树的关键:

1.连通图(只有一个根节点)

2.无环

3.每个节点入度为1(根节点为0)。

也就是说,

1.最后只有一个集合

2.合并的时候不能合并一个集合的两个节点

3.合并的时候子节点入度为0(子节点为根节点或子节点还未并入树)。

理清思路,就一步一步用代码来实现。

--------------------------------------------------------------------------------------------------

注意:

1.并查集的代码模型,和实际有向图模型并不是一个模型,不能等同模拟。只可以模拟有向树。

这个题如果有一个入度为1的节点加一个父节点,虽然代码上改子节点的编码还是一个,但实际图上已经有两个父节点了!

所以必须单独判断一下入度是否已经为1!

技术分享图片

2.这个题没给数据范围,开1005就够。

3.节点合并方向要注意一下,是a是b的父节点。

Code:

#include<stdio.h>
#include<string.h>
#include<algorithm>
const int N=1005;
using namespace std;
int f[N],mark[N];///父节点    标记是否入树
int find(int x)
{
    if(x==f[x])
        return x;
    return find(f[x]);
}
void merge(int x,int y)
{
    int t1=find(x);
    int t2=find(y);
    if(t1!=t2)             ///合并
        f[t2]=t1;
}
int main()
{
    int a,b,k=1;
    while(1)
    {
        memset(mark,0,sizeof(mark));///清空
        for(int i=0; i<1005; i++)
            f[i]=i;
        int flag=0;
        while(~scanf("%d %d",&a,&b))
        {
            if(a<0&&b<0)return 0;///结束条件
            if(a==0&&b==0)break;///空树
            if(find(a)==find(b)||find(b)!=b)
        ///不能合并一个集合的两个节点      单独判断节点入度是否为1(b为子节点)
                flag=1;
            else merge(a,b);
            mark[a]=1,mark[b]=1;///标记已入树
        }
        int ans=0;
        for(int i=0; i<1005; i++)
        {
            if(mark[i]&&find(i)==i)///只能有一个根
                ans++;
        }
        if(ans>1)flag=1;
        if(flag)
            printf("Case %d is not a tree.\n",k++);
        else printf("Case %d is a tree.\n",k++);
    }
    return 0;
}

哈哈哈~

又解决一道题

已经走远的人没必要在原地等你~

  • 10
    点赞
  • 19
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 7
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值