HDU-1133 Word Amalgamation 字符串处理

HDU-1133 Word Amalgamation

原题链接🔗,点击进入

Problem Description

In millions of newspapers across the United States there is a word game called
Jumble. The object of this game is to solve a riddle, but in order to find the letters 
that appear in the answer it is necessary to unscramble four words. Your task is to 
write a program that can unscramble words.

Input

The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of  
lowercase English letters and will be at least one and at most six characters long.
(Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not 
necessarily in sorted order, but each word in the dictionary is unique.

Output

For each scrambled word in the input, output an alphabetical list of all dictionary 
words that can be formed by rearranging the letters in the scrambled word. Each 
word in this list must appear on a line by itself. If the list is empty (because no 
dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In 
either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

题目大意:

给你一个字典集合和一个乱码集合,要求在乱码中识别每个乱码能否通过任意的组合,形成字典中已有的单词,能则输出字典中的单词,否则输出 “NOT A VALID WORD”

思路:

刚看题的时候,萌生的最原始,最暴力的方法就是将每个单词中出现的字母和乱码中出现的字母进行比较,如果两个出现的字母完全相同,则乱码可以形成单词,否则就不能。相比之下,直接使用map+string的代码量和思路是应该是最简单和清晰的!
(注意:本题输出要求输出单词的顺序按照字典序输出,所以如果是没有使用map的解法,就必须对结果集合进行sort.)

AC代码

解法一(string数组):

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
string dict[1005];
string str[1005];
int marka[26];
int markb[26];
void init()
{
    for(int i = 0; i < 26; i++){
        marka[i] = markb[i] = 0;
    }
}
int judge(string a, string b, int len)
{
    init();//初始化两个标记数组
    for(int i = 0; i < len; i++){
        marka[a[i]-'a']++;
        markb[b[i]-'a']++;
    }
    int flag = 0;
    for(int i = 0; i < 26; i++){
        if(marka[i] == markb[i]){
            if(marka[i] != 0){ //都出现了
                flag = 1;
                continue;
            }
        }
        else{  //出现了一个
            flag = 0;
            break;
        }
    }
    return flag;
}
bool cmp(string a, string b){
    return a < b;
}
int main() {
    string s1;
    int cnt1 = 0;
    int cnt2 = 0;
    while(cin >> s1){
        if(s1 == "XXXXXX")
            break;
        dict[cnt1++] = s1;
    }
    string s2;
    while(cin >> s2){
        if(s2 == "XXXXXX")
            break;
        str[cnt2++] = s2;
    }
    
    for(int i = 0; i < cnt2; i++){  //乱码
        string a = str[i];
        int v = 0;
        string tmp[100];
        for(int j = 0; j < cnt1; j++){  //字典
            string b = dict[j];
            if(a.length() == b.length()){  //长度相同
                if(judge(a, b, a.length())){  
                    tmp[v++] = dict[j];
                }
            }

        }
        if(v == 0){
            cout << "NOT A VALID WORD" << endl;
        }
        else{
            sort(tmp,tmp+v,cmp);
            for(int i = 0; i < v; i++){
                cout << tmp[i] << endl;
            }
        }
        cout << "******" << endl;
    }
    return 0;
}

解法二(map + string):

#include <iostream>
#include <stdio.h>
#include <map>
#include <algorithm>
#include <string>
using namespace std;
map<string, string> mp;
int main() {
	string s1,s2;
	string t;
	while(cin >> s1){
		t = s1;
		if(t == "XXXXXX")
			break;
		sort(s1.begin(), s1.end());
		mp[t] = s1;
	}
	while(cin >> s2){
		if(s2 == "XXXXXX")
			break;
		sort(s2.begin(),s2.end());
		map<string, string> ::iterator it;
		int flag = 0;
		for(it = mp.begin(); it != mp.end(); it++){
			if(it->second == s2){
				cout << it->first << endl;
				flag = 1;
			}
		}
		if(flag == 0){
			cout << "NOT A VALID WORD" << endl;
		}
		cout << "******" << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值