pta7-3表达式转换

题目:
算术表达式有前缀表示法、中缀表示法和后缀表示法等形式。日常使用的算术表达式是采用中缀表示法,即二元运算符位于两个运算数中间。请设计程序将中缀表达式转换为后缀表达式。

输入格式:
输入在一行中给出不含空格的中缀表达式,可包含+、-、*、\以及左右括号(),表达式不超过20个字符。

输出格式:
在一行中输出转换后的后缀表达式,要求不同对象(运算数、运算符号)之间以空格分隔,但结尾不得有多余空格。

输入样例:
2+3*(7-4)+8/4

输出样例:
2 3 7 4 - * + 8 4 / +

#include<iostream>
#include<stdio.h>
#include<stack>
#include<unordered_map>
#include<queue>
using namespace std;
unordered_map<char, int>yxj{ {'+',1},{'-',1},{'*',2},{'/',2},{'(',3},{')',3} };
stack<char>res;

int main() {
	string s;
	cin >> s;
	//int flag = 0;
	int idx = 0;
	for (int i = 0; i < s.size(); i++) {
		if (isdigit(s[i]) || (i < 1 || s[i - 1] == '(') && (s[i] == '+' || s[i] == '-') || s[i] == '.') {
			//注意可能有小数
			//判断开头是负数或者(后出现的第一个数是负数
			if (idx)cout << " ";
			idx++;
			if (s[i] != '+')
			cout << s[i];//可能是负数
			while (isdigit(s[i+1])||s[i+1]=='.') {
				cout << s[i+1];
				i++;
			}
		}
		else {
			if (s[i] == ')') {
				while (res.size()>0 && res.top() != '(') {
					cout << " " << res.top();
					res.pop();
				}
				res.pop();
			}
			else if (res.size()==0||yxj[s[i]]>yxj[res.top()]) {
				res.push(s[i]);
			}
			else {
				while (res.size()>0 && res.top() != '(') {
					cout << " " << res.top();
					res.pop();
				}
				res.push(s[i]);
			}
		}
		
	}
	while (!res.empty()) {
		cout << " " << res.top();
		res.pop();
	}
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值