Description
世界上存在着N个国家,简单起见,编号从0~N-1,假如a国和b国是盟国,b国和c国是盟国,那么a国和c国也是盟国。另外每个国家都有权宣布退盟(注意,退盟后还可以再结盟)。
定义下面两个操作:
“M X Y” :X国和Y国结盟 (如果X与Z结盟,Y与Z结盟,那么X与Y也自动结盟).
“S X” :X国宣布退盟 (如果X与Z结盟,Y与Z结盟,Z退盟,那么X与Y还是联盟).
Input
多组case。
每组case输入一个N和M (1 ≤ N ≤ 100000 , 1 ≤ M ≤ 1000000),N是国家数,M是操作数。
接下来输入M行操作
当N=0,M=0时,结束输入
Output
对每组case输出最终有多少个联盟(如果一个国家不与任何国家联盟,它也算一个独立的联盟),格式见样例。
Sample Input
5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3
3 1
M 1 2
0 0
Sample Output
Case #1: 3
Case #2: 2
#include<bits/stdc++.h>
using namespace std;
#define pi acos(-1)
#define mod 1000000007
#define ll long long
#define ull unsigned long long
#define mem(a) memset(a,0,sizeof(a))
#define cio ios::sync_with_stdio(false)
const int maxn = 2000005;
int q[2000010]; // 并查集
int a[2000010]; // 存储每个点的id,由于将退出的国家重新编号所以用数组记录
set<int>k; // 存储联盟个数
int ffind(int x) // 并查集模板
{
if(x==q[x]){
return q[x];
}else{
return q[x] = ffind(q[x]);
}
}
void com(int x, int y)
{
int xx = ffind(a[x]); // 由于使用数组a存储每个元素的编号
int yy = ffind(a[y]); // 所以这里找根节点的时候是a[x]和a[y]
if(xx!=yy) q[xx] = yy;
}
int main()
{
int n, m;
int t = 1;
while(cin>>n>>m){
if(n==0&&m==0) break;
for(int i = 0; i < maxn; i++) q[i] = i; // 初始化所有可能节点的编号
for(int i = 0; i < n; i++) a[i] = i; // 初始化n个国家的编号
int cnt = n; // 将退出联盟的国家从n开始编号
while(m--){
char op;
cin >> op;
if(op=='M'){
int x, y;
cin >> x >> y;
com(x,y);
}else{
int x;
cin >> x;
a[x] = cnt++;
}
}
k.clear();
for(int i = 0; i < n; i++) k.insert(ffind(a[i])); // 将每个国家的联盟放进set,利用set统计联盟个数
cout << "Case #" << t++ << ": " << k.size() << endl;
}
return 0;
}