题目描述
编写一个程序实现将字符串中的所有"you"替换成"we"
输入
输入包含多行数据 每行数据是一个字符串,长度不超过1000 数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do
代码
#include<stdio.h>
#include<iostream>
using namespace std;
int main(){
char str[1001];
while(gets(str)!=NULL){
for( int i=0;str[i]!='\0';i++){
if(str[i]=='y'&& str[i+1]=='o'&& str[i+2]=='u'){
printf("we");//直接输出
i+=2;//
}
else{
printf("%c",str[i]);
}
}
// printf("\0");
printf("\n");
}
return 0;
}