1037 Magic Coupon (25 分)

需要查看代码请看通过代码栏目。

原题

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC , followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC ,NP≤10^5, and it is guaranteed that all the numbers will not exceed 2^30.

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
结尾无空行

Sample Output:
43
结尾无空行

我的思路 

一开始的想法是,每次找最大的两个正数相乘,任何一组的正数找完了就找最小的两个负数相乘,这种方法思路简单,没报bug一次就跑起来了,但是测试用例中有一组运行超时了(每次都要遍历找最大或者最小,那么多循环能不超时吗?/doge)。

 于是变换思路,将两组数据先各自排序,然后按序相乘(正数从大到小相乘,负数从小到大相乘)。

通过代码

#include <bits/stdc++.h>
using namespace std;
int main(){
    long long *c,*p,total=0,result=0;
    int cn,pn;
    scanf("%d",&cn);
    c=(long long *)malloc(sizeof(long long)*(cn));
    for(int i = 0;i<=cn-1;i++){
        scanf("%lld",&c[i]);
    }
    scanf("%d",&pn);
    p=(long long *)malloc(sizeof(long long)*(pn));
    for(int i = 0;i<=pn-1;i++){
        scanf("%lld",&p[i]);
    }
    sort(c,c+cn);
    sort(p,p+pn);
    if(cn==0 || pn==0){
        printf("%lld",total);
        return 0;
    }
    int i=0;
    while(i<cn&&i<pn&&c[i]<0&&p[i]<0){
        result=c[i]*p[i];
        total+=result;
        i++;
    }
    i=0;
    while(i<cn&&i<pn&&c[cn-1-i]>0&&p[pn-1-i]>0){
        result=c[cn-1-i]*p[pn-1-i];
        total+=result;
        i++;
    }
    printf("%lld",total);
    return 0;
}

总结

我的思路中需要判断两负数相乘的项是不是乘完了(正数一样的),于是一开始用了下面的这个简单判断的方法,想的是如果一组数据里面的负数已经处理完了,本轮出现正数,另一组负数还有剩,本轮依然是负数,这样乘出来得到的就会是一个负数(result<=0),这时退出循环就好。

while(i<cn&&i<pn){
        result=c[cn-1-i]*p[pn-1-i];
        if(result<=0)  break;
        else{
            total+=result;
            i++;
        }
    }

这个判断方法在我自己用的几个例子上确实没有问题,例如:

4
1 2 4 -1
4
7 6 -2 -3

但忽略了一种情况,就是两组负数的个数一样,同时轮完负数且没有0,这时就无法按上述判例退出循环,例如:

5
-3 -2 1 2 3
4
-4 -3 2 5

呜呜,暂时没有想到下次如何避免这种问题,先死记吧。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值