1043: 最大值

54 篇文章 3 订阅

使用C++编写程序

题目描述

输入一个整数n和n个整数,输出这n个整数的最大值。

输入

输入有两行:第一行是一个正整数n,第二行是n个整数。

输出

输出包含一个整数,即n个数中的最大值,单独占一行。

样例输入 Copy

4
3 7 5 6

样例输出 Copy

7

程序代码如下
#include<iostream>
#include<vector>                       //顺序容器vector的头文件
#include<algorithm>                    //max_element()的头文件
#define ElemType_I int

using namespace std;

template<class ElemType>               //类模板
class MaxNumber
{
public:
	MaxNumber(ElemType N);
	void GetMaxValue();
private:
	vector<ElemType> Number;
};

template<class ElemType>
inline MaxNumber<ElemType>::MaxNumber(ElemType N)
{
	for (int i = 0; i < N; i++)
	{
		ElemType Value;
		cin >> Value;
		Number.push_back(Value);
	}
}

template<class ElemType>
inline void MaxNumber<ElemType>::GetMaxValue()
{
	cout << *max_element(Number.begin(), Number.end());
}

int main()
{
	ElemType_I N;
	cin >> N;
	MaxNumber<ElemType_I> MaxValue(N);
	MaxValue.GetMaxValue();
	return 0;
}
程序运行结果如下

在这里插入图片描述

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值