Codeforces Round #627 (Div. 3) E - Sleeping Schedule (线性dp)

**E Sleeping Schedule **

题目描述
Vova had a pretty weird sleeping schedule. There are h hours in a day. Vova will sleep exactly n times. The i-th time he will sleep exactly after ai hours from the time he woke up. You can assume that Vova woke up exactly at the beginning of this story (the initial time is 0). Each time Vova sleeps exactly one day (in other words, h hours).

Vova thinks that the i-th sleeping time is good if he starts to sleep between hours l and r inclusive.

Vova can control himself and before the i-th time can choose between two options: go to sleep after ai hours or after ai−1 hours.

Your task is to say the maximum number of good sleeping times Vova can obtain if he acts optimally.

Input

The first line of the input contains four integers n,h,l and r (1≤n≤2000,3≤h≤2000,0≤l≤r<h) — the number of times Vova goes to sleep, the number of hours in a day and the segment of the good sleeping time.

The second line of the input contains n integers a1,a2,…,an (1≤ai<h), where ai is the number of hours after which Vova goes to sleep the i-th time.

Output

Print one integer — the maximum number of good sleeping times Vova can obtain if he acts optimally.

Example Input

7 24 21 23
16 17 14 20 20 11 22

Example Output

3

Note

The maximum number of good times in the example is 3.

The story starts from t=0. Then Vova goes to sleep after a1−1 hours, now the time is 15. This time is not good. Then Vova goes to sleep after a2−1 hours, now the time is 15+16=7. This time is also not good. Then Vova goes to sleep after a3 hours, now the time is 7+14=21. This time is good. Then Vova goes to sleep after a4−1 hours, now the time is 21+19=16. This time is not good. Then Vova goes to sleep after a5 hours, now the time is 16+20=12. This time is not good. Then Vova goes to sleep after a6 hours, now the time is 12+11=23. This time is good. Then Vova goes to sleep after a7 hours, now the time is 23+22=21. This time is also good.

题目大意

一个人每天从0点开始睡觉 ,睡n次觉,每天共h小时,每次可以选择睡ai时间或者ai - 1时间,当醒来时在l到r区间时,算一次 good time,求maximum number of good sleeping times.

Solution

动态规划。
每次决策依赖于上一次的时间,定义 dp[ i ][ j ]为前i次睡觉j次选择睡ai时间所能获得的最大good sleeping times。
(或者定义dp[i][j]为前i次睡觉在j时间醒来的最大good sleeping times)。

按第一种定义方法,先处理一个前i次均按ai睡眠的前缀和。
每次的新时间为 (num[i] - (i - j) ) % h;

状态转移
dp[i][j] = max(dp[i - 1][j] , dp[i - 1][j - 1]) + temp;
第一种是第i次睡觉选择ai - 1时间。
第二种是第i次睡觉选择ai时间。

答案即为dp[n][i]的最大值。

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

typedef long long ll;
const int SZ = 2000 + 200;

int num[SZ],x,n,h,l,r,dp[SZ][SZ],ans,a[SZ];

int main()
{
	scanf("%d%d%d%d",&n,&h,&l,&r);
	for(int i = 1;i <= n;i ++ )
	{
		scanf("%d",&a[i]);
		num[i] = num[i - 1] + a[i];
	}	
	for(int i = 1;i <= n;i ++ )
		for(int j = 0;j <= i;j ++ )
		{
			if(j == 0)
			{
				int	temp = (num[i] - i) % h;
				if(temp >= l && temp <= r) temp = 1;
				else temp = 0; 
				 dp[i][j] = dp[i - 1][j] + temp;
			}
			else 
			{
				int temp1;
				temp1 = (num[i] - (i - j)) % h;
				if(temp1 >= l && temp1 <= r) temp1 = 1;
				else temp1 = 0;
				dp[i][j] = max(dp[i - 1][j] + temp1,dp[i - 1][j - 1] + temp1);
			}
		}
		for(int i = 0;i <= n;i ++ )
		ans = max(ans,dp[n][i]);
	printf("%d\n",ans);
	return 0;
} 

2020.3.14

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值