HDU - 6557 Justice

题目
Put simply, the Justice card represents justice, fairness, truth and the law. You are being called to account for your actions and will be judged accordingly. If you have acted in a way that is in alignment with your Higher Self and for the greater good of others, you have nothing to worry about. However, if you have
acted in a way that is out of alignment, you will be called out and required to own up to your actions. If this has you shaking in your boots, know that the Justice card isn’t as black and white as you may think.

On the table there are n weights. On the body of the i-th weight carved a positive integer ki , indicating that its weight is 1/2ki gram. Is it possible to divide the n weights into two groups and make sure that the sum of the weights in each group is greater or equal to 1/2 gram? That’s on your call. And please tell us how if possible.
Input
In the first line of the input there is a positive integer T (1 ≤ T ≤ 2000), indicating there are T testcases.
In the first line of each of the T testcases, there is a positive integer n (1 ≤ n ≤ 105, ∑n ≤ 7 × 105), indicating there are n weights on the table.
In the next line, there are n integers ki (1 ≤ ki ≤ 109), indicating the number carved on each weight.
Output
For each testcase, first print Case i: ANSWER in one line, i indicating the case number starting from 1 and ANSWER should be either YES or NO, indicating whether or not it is possible to divide the weights. Pay attention to the space between : and ANSWER.
If it’s possible, you should continue to output the dividing solution by print a 0/1 string of length n in the next line. The i-th character in the string indicating whether you choose to put the i-th weight in group 0 or group 1.
Sample Input
3
3
2 2 2
3
2 2 1
2
1 1
Sample Output
Case 1: NO
Case 2: YES
001
Case 3: YES
10

题意
给n个砝码,每个编号ki,每个砝码重量1/2ki,问能不能把所有砝码分成两组,每一组的重量和都不小于1/2,如果可以,给出分组方案

思路
用map记录现在的编号ki的数量,如果有两个ki就合成一个ki-1。

代码

#include<bits/stdc++.h>
using namespace std;

#define ll long long
#define IO ios::sync_with_stdio(false);cin.tie(0);cout.tie(0)

const int MAXN = 1e5 + 5;

int t, n;
struct node {
	int k, num;
}a[MAXN];

bool cmp(node a, node b) {
	return a.k < b.k;
}
int ans[MAXN];
unordered_map<int,int> mp;
int main(void) {
	IO;
	cin >> t;
	for(int c = 1; c <= t; c++) {
		cout << "Case " << c << ": ";
		
		memset(ans, 0, sizeof(ans));
		cin >> n;
		for(int i = 1; i <= n; i++) {
			cin >> a[i].k;
			a[i].num = i;
		}
		sort(a + 1, a + n + 1, &cmp);
		
		mp.clear();
		int now, pos = -1;
		for(int i = 1; i <= n; i++) {
			now = a[i].k;
			while(now >= 2 && mp[now]) mp[now] = 0, now--;
			mp[now] = 1;
			if(now == 1) {
				pos = i + 1;
				break;
			}
		}
		if(pos == -1) {
			cout << "NO" << '\n';
			continue;
		}
		
		mp.clear();
		for(int i = pos; i <= n; i++) {
			now = a[i].k;
			ans[a[i].num] = 1;
			while(now >= 2 && mp[now]) mp[now] = 0, now--;
			mp[now] = 1;
			if(now == 1) {
				pos = -1;
				break;
			}
		}
		if(pos == -1){
			cout << "YES" << '\n';
			for(int i = 1; i <= n; i++) {
				cout << ans[i];
			}
			cout << '\n';
		}else {
			cout << "NO" << '\n';
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值