OJ 1517 Required Remainder

描述
You are given three in taggers x, y and n. Your task is to find the maximum integer k such that0≤k≤n 0≤k≤nthatk mod x=y k mod x=y, where mod is modulo operation. Many programming languages use percent operator % to implement it.
In other words, with give x, y, and n you need to find the maximum possible integer from0tonthat has the remainder y modulo x.
You have to answer t independent test cases. It is guaranteed that suchk exists for each test case.
输入
The first line of the input contains one integer t(1≤t≤5⋅10^41≤t≤5⋅10^4) — the number of test cases. The next t lines contain test cases.
The only line of the test case contains three integers x, y and n(2≤x≤10^9;0≤y<x;y≤n≤10^92≤x≤10^9;0≤y<x;y≤n≤10^9).
It can be shown that such k always exists under the given constraints.
输出
For each test case, print the answer —maximum non-negative integer k k such that 0≤k≤n0≤k≤nandkmodx=y k mod x=y. It is guaranteed that the answer always exists.
输入样例 1
7
7 5 12345
5 0 4
10 5 15
17 8 54321
499999993 9 1000000000
10 5 187
2 0 999999999
输出样例 1
12339
0
15
54306
999999995
185
999999998
 

 

题目要求是找出0到n中最大的对x取余等于y的数,那么我们可以先让n减去y然后除x在用除得的结果乘x由于int类型除法直接抹除余数的特性得到的数就是最大的能整除x的数。然后加上y得到的就是最大的对x取余等于y的数

#include <iostream>

using namespace std;

int main()
{
   int T;
   long x,y,n;
   while(cin>>T)
   {
       while(T--)
       {
           cin>>x>>y>>n;
           cout<<((n-y)/x)*x+y<<endl;
       }
   }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值