ZOJ Problem 1005 jugs

题目


In the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.

You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.

A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are

fill A
fill B
empty A
empty B
pour A B
pour B A
success

where "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished.

You may assume that the input you are given does have a solution.

Input

Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca <= Cb and N <= Cb <=1000 and that A and B are relatively prime to one another.

Output

Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line "success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces.

 

Sample Input

3 5 4
5 7 3

Sample Output

fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success

解析


从翻译中得知题目要求通过题目所给操作使得B中的水量为限定值,首先需要考虑当B的容量等于C(B为1时B等于C),此时只需倒满B;其次时A的容量为1或者A等于C,这是只需要把A填满并且倒入B直到B中容量合格为止;如果前面两个条件都不满足则选取大于限定值的最小容量的罐子,将其填满并将其倒入另一个罐子,如果那个罐子空了则将其倒满,如果另一个罐子满了就将其倒空,否则继续将水倒入另一个罐子中直到B达到限定值。


代码


#include <iostream>

using namespace std;
int ca,cb,a,b,c,t;
void FillA()
{
    ca=a;
    cout<<"fill A"<<endl;
}
void FillB()
{
    cb=b;
    cout<<"fill B"<<endl;
}
void pourAB ()
{
    t=ca-(b-cb);
    if(t<=0)
    {
        cb+=ca;
        ca=0;
    }
    else
    {
        ca=t;
        cb=b;
    }
    cout<<"pour A B"<<endl;
}
void pourBA()
{
    t=cb-(a-ca);
    if(t<=0)
    {
        ca+=cb;
        cb=0;
    }
    else
    {
        cb=t;
        ca=a;
    }
    cout<<"pour B A"<<endl;
}
void EmptyA ()
{
    ca=0;
    cout<<"empty A"<<endl;
}
void EmptyB ()
{
    cb=0;
    cout<<"empty B"<<endl;
}
int main()
{
    while(cin>>a>>b>>c)
    {
        ca=0,cb=0;

        if (b==c)
        {
                FillB();
        }
        else if (a==c||a==1)
        {
            while(cb<c)
            {
                FillA();
                pourAB();
            }
        }
        else if (a<c)
        {
            FillB();
            pourBA();
            while(cb!=c)
            {

                if(ca==a)
                    EmptyA();
                if (cb==0)
                    FillB();
                else
                    pourBA();
            }
        }
        else if (a>c)
        {
            FillA();
            pourAB();
            while(cb!=c)
            {

                if(cb==b)
                    EmptyB();
                if (ca==0)
                    FillA();
                else
                    pourAB();
            }
        }
        cout<<"success"<<endl;

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值