PTA写BUG日志——活用递推、打表以及其他一些算法的奇淫巧计(算法笔记上机实战)

活用递推第一弹

PTA 甲级1093、乙级1040

1093 Count PAT’s (25 分)

The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.
Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
​5
​​ characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2

这题不是很难,是假期以来俺最快写完的题目之一别笑
思路是打表,有斐波那契数列的味道啦,总体而言思路不会特别难:

  • p[i]=p[i-1]+1(如果str[i]=p)
  • pa[i]=pa[i-1]+p[i-1] (如果str[i]=a)
  • pat[i]=pa[i-1]+pat[i-1] (如果str[i]=t)

代码:

//1093
#include<bits/stdc++.h>
using namespace std;
const int mode=1000000007;
const int maxn=200000;
char str[maxn];
int p[maxn]={0};
int pa[maxn]={0};
int pat[maxn]={0};
int main(){
	scanf("%s",&str);
	int len=strlen(str);
	for(int i=0;i<len;i++){
		if(i==0){
			if(str[i]=='P'){
				p[i]=1; 
			}
			continue;
		}
		if(str[i]=='P'){
			p[i]=(p[i-1]+1)%mode;
		}else{
			p[i]=p[i-1]%mode;
		}	
		if(str[i]=='A'){
			pa[i]=(pa[i-1]+p[i-1])%mode;
		}else{
			pa[i]=pa[i-1]%mode;
		}
		if(str[i]=='T'){
			pat[i]=(pat[i-1]+pa[i-1])%mode;
		}else{
			pat[i]=pat[i-1]%mode;
		}
	}
	printf("%d",pat[len-1]);
	return 0;
} 

活用递推第二弹

PTA 甲级1101 乙级1145
1101 Quick Sort (25 分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?
For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
​5
​​ ). Then the next line contains N distinct positive integers no larger than 10
​9
​​ . The numbers in a line are separated by spaces.

Output Specification:
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5

这题和上一题思路类似,先从右往左再从左往右遍历数组,分别找出从[1,i]最大的和[i,n-1]最小的,最后再循环一次存储答案。

注意** 输出答案的时候 格式问题**
🕳点在于:当答案为0个时候,要多输出一行“\n”

AC代码:

//1101
#include<bits/stdc++.h>
using namespace std;
//判断左边都是小于等于,右边全是大于等于
const int maxn=100100;
int num[maxn];
vector<int>ans;
int n; 
int left_max[maxn]={0};//左边最大的 
int right_min[maxn]={0};//右边最小的 
int main(){
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%d",&num[i]);
		left_max[i]=max(left_max[i-1],num[i]);
	}
	right_min[n-1]=999999999;
	
	//printf("debug:%d\n",right_min[n-1]);
	
	for(int i=n-2;i>=0;i--){
		right_min[i]=min(num[i],right_min[i+1]);
	}

	for(int i=1;i<=n;i++){
		if(i==n&&num[i]>=left_max[i]){
		
			ans.push_back(num[i]);
		}
		if(num[i]<=right_min[i]&&num[i]>=left_max[i]){
		
			ans.push_back(num[i]);
		}
	}
	printf("%d\n",ans.size());
	//vector排序
	sort(ans.begin(),ans.end()); 
	for(int i=0;i<ans.size();i++){
		if(i==0)
		printf("%d",ans[i]);
		else{
			printf(" %d",ans[i]);
		}
	}
	if(ans.size()==0)printf("\n");
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值