团体程序设计天梯赛-练习集-L1-005 考试座位号

团体程序设计天梯赛-练习集

L1-005 考试座位号 (15 分)

每个 PAT 考生在参加考试时都会被分配两个座位号,一个是试机座位,一个是考试座位。正常情况下,考生在入场时先得到试机座位号码,入座进入试机状态后,系统会显示该考生的考试座位号码,考试时考生需要换到考试座位就座。但有些考生迟到了,试机已经结束,他们只能拿着领到的试机座位号码求助于你,从后台查出他们的考试座位号码。

输入格式:
输入第一行给出一个正整数 N(≤1000),随后 N 行,每行给出一个考生的信息:准考证号 试机座位号 考试座位号。其中准考证号由 16 位数字组成,座位从 1 到 N 编号。输入保证每个人的准考证号都不同,并且任何时候都不会把两个人分配到同一个座位上。

考生信息之后,给出一个正整数 M(≤N),随后一行中给出 M 个待查询的试机座位号码,以空格分隔。

输出格式:
对应每个需要查询的试机座位号码,在一行中输出对应考生的准考证号和考试座位号码,中间用 1 个空格分隔。

输入样例:
4
3310120150912233 2 4
3310120150912119 4 1
3310120150912126 1 3
3310120150912002 3 2
2
3 4
输出样例:
3310120150912002 2
3310120150912119 1

很容易想到第一种方法

package 团体程序设计天梯赛练习集;

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class 考试座位号 {
    private static List<String[]> list = new ArrayList<>();//学生信息
    private  static  List<Integer> list2= new ArrayList<>();

    public static void main(String[] args) {
        Scanner sc= new Scanner(System.in);
        int n = sc.nextInt();
        for (int i = 0; i <n ; i++) {
            SetData(sc);//读取学生数据
        }
        int m = sc.nextInt();//获取需要查询的学生数据
        for (int i = 0; i < m ; i++) {
            int a = sc.nextInt();//学生编号
            list2.add(a);
        }
        for (int a : list2){
            GetData(a);//输出学生数据
        }
    }
    static  void GetData(int a){
        for(String[] data : list){
            if(Integer.parseInt(data[1]) == a){
                System.out.println(data[0]+" "+ data[2]);
            }
        }
    }

    static void SetData(Scanner sc){
        String a = sc.next();
        String b = sc.next();
        String c = sc.next();
        String[] data = new String[3];
        data[0] = a;
        data[1] = b;
        data[2] = c;
        list.add(data);
    }

}

但是会出现运行超时

在这里插入图片描述
换个角度,用 两个数组分别存储学生数据,牺牲内存,换取速度

于是写出


import java.util.Scanner;

public class Main {
    private  static  String[] code = new String[1001];//准考证号
    private  static  int[] code2 = new int[1001];//考试座位号

    public static void main(String[] args) {
        Scanner sc= new Scanner(System.in);
        int n = sc.nextInt();
        for (int i = 0; i <n ; i++) {
            String a = sc.next();
            int b = sc.nextInt();
            int c = sc.nextInt();
            code[b] = a;
            code2[b] = c;
        }
        int m = sc.nextInt();//获取需要查询的学生数据
        for (int i = 0; i < m ; i++) {
            int a = sc.nextInt();//学生编号
            System.out.println(code[a]+" "+ code2[a]);
        }
    }
}

用数组代替集合,节约遍历集合所需时间
但是很奇怪
这样也是超时的

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值