题目描述
写一个程序把一个字符串 s s s,可能含有空格,长度 ∣ s ∣ |s| ∣s∣, 1 ≤ ∣ s ∣ ≤ 1000 1 \le |s| \le 1000 1≤∣s∣≤1000 中的小写字母转化为大写字母。
输入
输入只有一行,可以包含数字大小写字母
输出
同样是一串字符串,只是将输入串中的小写字母转换成大写输出,其他不变
样例输入
abcABC abcxyz123
样例输出
ABCABC ABCXYZ123
#include<bits/stdc++.h>
using namespace std;
int main(){
char a[1000];
gets(a);
for(int j=0;a[j]!='\0';j++)
{
if('a'<=a[j] and a[j]<='z')a[j]-=32; //if(islower(a[j]))a[j]-=32;
else continue;
}
for(int j=0;a[j]!='\0';j++)
{
cout<<a[j];
}
return 0;
}