SDUT-链表的节点插入

师–链表的结点插入

Problem Description
出一个只有头指针的链表和 n 次操作,每次操作为在链表的第 m 个元素后面插入一个新元素x。若m 大于链表的元素总数则将x放在链表的最后。

Input
组输入。每组数据首先输入一个整数n(n∈[1,100]),代表有n次操作。
接下来的n行,每行有两个整数Mi(Mi∈[0,10000]),Xi。

Output
于每组数据。从前到后输出链表的所有元素,两个元素之间用空格隔开。

Sample Input
4
1 1
1 2
0 3
100 4

Sample Output
3 1 2 4

Hint
例中第一次操作1 1,由于此时链表中没有元素,1>0,所以此时将第一个数据插入到链表的最后,也就是头指针的后面

#include <bits/stdc++.h>
using namespace std;
struct node
{
  int data;
  struct node *next;
};
int main()
{
    int num,n,m,x;
    struct node *head,*tail,*p;
    while(scanf("%d",&n)!=EOF)
    {
        num=0;
        head=(struct node *)malloc(sizeof(struct node));
        head->next=NULL;
        while(n--)  /*插入n个元素*/
        {
            tail=head;
            scanf("%d %d",&m,&x);
            if(m>=num)
            {
                while(tail->next)
                    tail=tail->next;
                p=(struct node *)malloc(sizeof(struct node));
                p->data=x;
                tail->next=p;
                p->next=NULL;
                num++;
            }
            else
            {
                while(m--)
                tail=tail->next;
                p=(struct node *)malloc(sizeof(struct node));
                p->data=x;
                p->next=tail->next;
                tail->next=p;
                num++;
            }
        }
        tail=head->next;
        while(tail)
        {
            if(tail->next==NULL)
                printf("%d\n",tail->data);
            else
                printf("%d ",tail->data);
            tail=tail->next;
        }
    }
    return 0;
}

下面的代码在链表插入时没有进行多余的分类,感觉是简单了些

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int data;
    struct node *next;
};
int main()
{
    struct node *head,*tail,*p;
    int m,n,i;
    while(scanf("%d",&n)!=EOF)
    {
        head=(struct node *)malloc(sizeof(struct node));
        head->next=NULL;
        while(n--)
        {
            tail=head;
            p=(struct node *)malloc(sizeof(struct node));
            scanf("%d %d",&m,&p->data);
            for(i=1; i<=m; i++)
            {
                if(tail->next==NULL)
                    break;
                tail=tail->next;
            }
            p->next=tail->next;
            tail->next=p;
        }
        tail=head->next;
        while(tail)
        {
            if(tail->next==NULL)
                printf("%d\n",tail->data);
            else
                printf("%d ",tail->data);
            tail=tail->next;
        }
    }
    return 0;
}
  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值