求二叉树的层次遍历

求二叉树的层次遍历

Problem Description
已知一颗二叉树的前序遍历和中序遍历,求二叉树的层次遍历。

Input
输入数据有多组,输入T,代表有T组测试数据。每组数据有两个长度小于50的字符串,第一个字符串为前序遍历,第二个为中序遍历。

Output
每组输出这颗二叉树的层次遍历。

Sample Input
2
abc
bac
abdec
dbeac

Sample Output
abc
abcde

#include <bits/stdc++.h>
using namespace std;
char a[88],b[88];

struct node
{
    char data;
    struct node *lc,*rc;
};

struct node *creat(int len,char qst[],char zst[])
{
    struct node *root;
    if(len<=0)
        return NULL;
    root=(struct node *)malloc(sizeof(struct node));
    root->data=qst[0];
    int i;
    for(i=0; i<len; i++)
    {
        if(zst[i]==qst[0])
            break;
    }
    root->lc=creat(i,qst+1,zst);
    root->rc=creat(len-1-i,qst+1+i,zst+i+1);
    return root;
};

void cengxu(struct node *root)
{
    struct node *temp[88];
    int in =0,out=0 ;
    temp[in++]=root;
    while(out<in)
    {
        if(temp[out])
        {
            printf("%c",temp[out]->data);
            temp[in++]=temp[out]->lc;
            temp[in++]=temp[out]->rc;
        }
        out++;
    }
}

int main()
{
    int t;
    struct node *root;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s %s",a,b);
        int len=strlen(a);
        root=(struct node *)malloc(sizeof(struct node));
        root=creat(len,a,b);
        cengxu(root);
        printf("\n");
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值