数据结构实验之栈与队列二:一般算术表达式转换成后缀式-待更新

Problem Description
对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

Input
输入一个算术表达式,以‘#’字符作为结束标志。

Output
输出该表达式转换所得到的后缀式。

Sample Input
a*b+(c-d/e)*f#

Sample Output
abcde/-f+

实话实说哈,这个代码我还没看懂,主要是不知道表达式的中缀后缀形式;
但是实验快结束了, 我先记下来,马上更新!!

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int ok(char ch,char sh)
{
    if(sh=='(')
        return 1;
    if((ch=='*'||ch=='/'||ch=='%')&&(sh=='+'||sh=='-'))
        return 1;
    else return -1;
}
int main()
{
    int i=0,top=-1;
    char exp[1055],str[1005],ch;
    while(scanf("%c",&ch)&&ch!='#')
    {
        if(ch>='a'&&ch<='z')
            exp[i++]=ch;
        else if(ch=='(')
            str[++top]=ch;
        else if(ch==')')
        {
            while(top!=-1)
            {
                exp[i++]=str[top];
                top--;
                if(str[top]=='(')
                {
                    top--;
                    break;
                }
            }
        }
        else
        {
            if(top==-1||ok(ch,str[top])>0)
            {
                str[++top]=ch;
            }
            else
            {
                while(top>=0&&ok(ch,str[top])<0)
                {
                    exp[i++]=str[top--];
                }
                str[++top]=ch;
            }
        }
    }
    while(top!=-1)
        exp[i++]=str[top--];
    exp[i]='\0';
    printf("%s\n",exp);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值