POJ2010:DP+优先队列

Moo University - Financial Aid

题目链接

Time Limit: 1000MS

Memory Limit: 30000K

Description
Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,“Moo U” for short.

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1…2,000,000,000.

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university’s limited fund (whose total money is F, 0 <= F <= 2,000,000,000).

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.

Input

  • Line 1: Three space-separated integers N, C, and F

  • Lines 2…C+1: Two space-separated integers per line. The first is the calf’s CSAT score; the second integer is the required amount of financial aid the calf needs

Output

  • Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.

Sample Input
3 5 70
30 25
50 21
20 20
5 18
35 30
Sample Output
35

Hint
Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70.

Source
USACO 2004 March Green

这题是多输入

首先直接将他们的分数排序,从大到小还是从小到大都无所谓。假设这里从小到大排,然后就可以得知可取的中位数有哪些,毕竟是在N个数字中取中位数,中位数两边就都各有(N-1)/2个数字,那么假设下标从0开始,可取的中位数的起点就是(N-1)/2,终点就是C-1-(N-1)。然后题目中要求最大的中位数,但是也要满足总学费不能超过F。那么我们就还要得知每个中位数的两边的其他(N-1)个数字的费用的最小和,这里就可以用到DP和优先队列。这里中位数左边数字的最小和与右边的要分开求。假设dpl[i]的意义是下标为i的数字的左边其他数字中选(N-1)/2个数字的最小和,dpr[i]就相应代表右边的。先初始化:对于下标为(N-1)/2的数字,也就是最小的中位数,dpl显然是确定的了,这里求和的同时把每个元素的费用都压入一个最大堆(从大到小的优先队列)。然后对于后面的下标为i的中位数而言,只要下标为i-1的元素的费用比最大堆中的顶端元素小,也就是存在一个更小的情况,那么dpl[i]=dpl[i-1]-(顶端元素)+(下标为i-1元素的费用),否则,dpl[i]=dpl[i-1]。那么同理右边的dpr也是相似的求法。最后从大到小遍历中位数,判断中位数加两端的费用是否不超过F,只要遇到符合要求的立马break,打出答案,没找到那自然就是-1了。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
int N,C,F,lr,sum,flag,ans;
int dpl[100010],dpr[100010];
struct k
{
    int goal,fee;
}cow[100010];
priority_queue< int > q;
bool cmp(k a,k b)
{
    if(a.goal!=b.goal)
    return a.goal<b.goal;
    return a.fee<b.fee;
}
int main()
{
    while(cin>>N>>C>>F)
    {
        while(!q.empty())
            q.pop();
        lr=(N-1)/2,sum=0,flag=0;
        for(int i=0;i<C;++i)
            scanf("%d%d",&cow[i].goal,&cow[i].fee);
        sort(cow,cow+C,cmp);
        for(int i=0;i<lr;++i)
        {
            q.push(cow[i].fee);
            sum+=cow[i].fee;
        }
        dpl[lr]=sum;
        for(int i=lr+1;i<=C-1;++i)
        {
            if(!q.empty()&&cow[i-1].fee<q.top())
            {
                dpl[i]=dpl[i-1]-q.top()+cow[i-1].fee;
                q.pop();
                q.push(cow[i-1].fee);
            }
            else
                dpl[i]=dpl[i-1];
        }
        while(!q.empty())
            q.pop();
        sum=0;
        for(int i=C-1;i>C-1-lr;--i)
        {
            q.push(cow[i].fee);
            sum+=cow[i].fee;
        }
        dpr[C-1-lr]=sum;
        for(int i=C-1-lr-1;i>=0;--i)
        {
            if(!q.empty()&&cow[i+1].fee<q.top())
            {
                dpr[i]=dpr[i+1]-q.top()+cow[i+1].fee;
                q.pop();
                q.push(cow[i+1].fee);
            }
            else
                dpr[i]=dpr[i+1];
        }
        for(int i=C-1-lr;i>=lr;--i)
        {
            if(cow[i].fee+dpl[i]+dpr[i]<=F)
            {
                flag=1;
                ans=cow[i].goal;
                break;
            }
        }
        if(flag)
            printf("%d\n",ans);
        else
            printf("-1\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
完整版:https://download.csdn.net/download/qq_27595745/89522468 【课程大纲】 1-1 什么是java 1-2 认识java语言 1-3 java平台的体系结构 1-4 java SE环境安装和配置 2-1 java程序简介 2-2 计算机中的程序 2-3 java程序 2-4 java类库组织结构和文档 2-5 java虚拟机简介 2-6 java的垃圾回收器 2-7 java上机练习 3-1 java语言基础入门 3-2 数据的分类 3-3 标识符、关键字和常量 3-4 运算符 3-5 表达式 3-6 顺序结构和选择结构 3-7 循环语句 3-8 跳转语句 3-9 MyEclipse工具介绍 3-10 java基础知识章节练习 4-1 一维数组 4-2 数组应用 4-3 多维数组 4-4 排序算法 4-5 增强for循环 4-6 数组和排序算法章节练习 5-0 抽象和封装 5-1 面向过程的设计思想 5-2 面向对象的设计思想 5-3 抽象 5-4 封装 5-5 属性 5-6 方法的定义 5-7 this关键字 5-8 javaBean 5-9 包 package 5-10 抽象和封装章节练习 6-0 继承和多态 6-1 继承 6-2 object类 6-3 多态 6-4 访问修饰符 6-5 static修饰符 6-6 final修饰符 6-7 abstract修饰符 6-8 接口 6-9 继承和多态 章节练习 7-1 面向对象的分析与设计简介 7-2 对象模型建立 7-3 类之间的关系 7-4 软件的可维护与复用设计原则 7-5 面向对象的设计与分析 章节练习 8-1 内部类与包装器 8-2 对象包装器 8-3 装箱和拆箱 8-4 练习题 9-1 常用类介绍 9-2 StringBuffer和String Builder类 9-3 Rintime类的使用 9-4 日期类简介 9-5 java程序国际化的实现 9-6 Random类和Math类 9-7 枚举 9-8 练习题 10-1 java异常处理 10-2 认识异常 10-3 使用try和catch捕获异常 10-4 使用throw和throws引发异常 10-5 finally关键字 10-6 getMessage和printStackTrace方法 10-7 异常分类 10-8 自定义异常类 10-9 练习题 11-1 Java集合框架和泛型机制 11-2 Collection接口 11-3 Set接口实现类 11-4 List接口实现类 11-5 Map接口 11-6 Collections类 11-7 泛型概述 11-8 练习题 12-1 多线程 12-2 线程的生命周期 12-3 线程的调度和优先级 12-4 线程的同步 12-5 集合类的同步问题 12-6 用Timer类调度任务 12-7 练习题 13-1 Java IO 13-2 Java IO原理 13-3 流类的结构 13-4 文件流 13-5 缓冲流 13-6 转换流 13-7 数据流 13-8 打印流 13-9 对象流 13-10 随机存取文件流 13-11 zip文件流 13-12 练习题 14-1 图形用户界面设计 14-2 事件处理机制 14-3 AWT常用组件 14-4 swing简介 14-5 可视化开发swing组件 14-6 声音的播放和处理 14-7 2D图形的绘制 14-8 练习题 15-1 反射 15-2 使用Java反射机制 15-3 反射与动态代理 15-4 练习题 16-1 Java标注 16-2 JDK内置的基本标注类型 16-3 自定义标注类型 16-4 对标注进行标注 16-5 利用反射获取标注信息 16-6 练习题 17-1 顶目实战1-单机版五子棋游戏 17-2 总体设计 17-3 代码实现 17-4 程序的运行与发布 17-5 手动生成可执行JAR文件 17-6 练习题 18-1 Java数据库编程 18-2 JDBC类和接口 18-3 JDBC操作SQL 18-4 JDBC基本示例 18-5 JDBC应用示例 18-6 练习题 19-1 。。。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值