PAT甲级 1004 Counting Leaves (30分)

1004 Counting Leaves (30分)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题目大意:

给出一个N叉树,计算每层的叶子结点数。

分析:

计算每层的叶子结点,可以利用BFS模板。
模板:二叉树的层序遍历(BFS) C++
都是利用队列先进先出的逻辑,来一层一层遍历树。
唯一不同的是,这题数的数据储存在数组里,所以需要通过数组建树。

树的结构

struct node{
	vector<int> child;//储存子节点的编号。
}Node[105];

C++

#include<bits/stdc++.h> 
using namespace std;
vector<int> res;
struct node{
	vector<int> child;
}Node[105];//储存结果。 
void layerOrder(int root){
	queue<int> que;
	que.push(root);
	while(!que.empty()){
		int size = que.size();
		int cnt = 0;
		for(int i = 0; i < size; i++){
			int front = que.front();
			que.pop();
			//层序遍历,符合队列先进先出的逻辑,借助队列完成层序遍历 
			if(Node[front].child.size() == 0) cnt++; //叶子结点
			else{//不是叶子结点,可以往下一层遍历 
				for(auto x : Node[front].child){
					que.push(x);
				}
			}
		}
		res.push_back(cnt);
	}
}
int main(){
	int m , n;
	cin >> n >> m;
	for(int i = 0; i < m; i++){
		int id, k;
		cin >> id >> k;
		while(k--){
			int ch;
			cin >> ch;
			Node[id].child.push_back(ch);
		}
	}
	layerOrder(1);
	cout<<res[0];
	for(int i = 1; i < res.size(); i++){
		cout<<" "<<res[i];
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值