PAT甲级 1005 Spell It Right (20分) C++ (模拟)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10
​100
​​ ).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

大意:

计算输入的各位数字之和,最后以英文形式输出。
比如1+2+3+4+5 = 15
最后依次输出one five

思路

模拟,利用string处理大数

C++

#include<bits/stdc++.h>
using namespace std;
int f(int x){
	string S = to_string(x);
	for(int i = 0 ; i < S.size(); i++){
		if(i != 0) cout<<" "; 
		switch(S[i]){
			case '0': cout<<"zero"; break;
			case '1': cout<<"one";break;
			case '2': cout<<"two";break;
			case '3': cout<<"three";break;
			case '4': cout<<"four";break;
			case '5': cout<<"five";break;
			case '6': cout<<"six";break;
			case '7': cout<<"seven";break;
			case '8': cout<<"eight";break;
			case '9': cout<<"nine";break;
		}
	}
}
int main(){
	string s; cin >> s;
	int sum = 0;
	for(auto x : s){
		sum += x - '0';
	}
	f(sum);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值