1015 德才论 (25分) Java

宋代史学家司马光在《资治通鉴》中有一段著名的“德才论”:“是故才德全尽谓之圣人,才德兼亡谓之愚人,德胜才谓之君子,才胜德谓之小人。凡取人之术,苟不得圣人,君子而与之,与其得小人,不若得愚人。”

现给出一批考生的德才分数,请根据司马光的理论给出录取排名。

输入格式:

输入第一行给出 3 个正整数,分别为:N(≤10^​5​​ ),即考生总数;L(≥60),
为录取最低分数线,即德分和才分均不低于 L 的考生才有资格被考虑录取;
H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,
此类考生按德才总分从高到低排序;
才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;
德才分均低于 H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,
但排在第二类考生之后;其他达到最低线 L 的考生也按总分排序,但排在第三类考生之后。

随后 N 行,每行给出一位考生的信息,包括:准考证号 德分 才分,其中准考证号为 8 位整数,德才分为区间 [0, 100] 内的整数。数字间以空格分隔。

输出格式:

输出第一行首先给出达到最低分数线的考生人数 M,随后 M 行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。

输入样例:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

输出样例:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

Java(超时)

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Collections;
import java.util.List;
public class Main {
    private static class Person implements Comparable<Person> {
        private int id;
        private int mora;
        private int talent;
        private int type;
        private int score;
        public Person(int id, int mora, int talent, int h) {
            this.id = id;
            this.mora = mora;
            this.talent = talent;
            this.score = this.mora + this.talent;
            if (mora >= h && talent >= h) 
                type = 1;
             else if (mora >= h && talent < h) 
                type = 2;
             else if (mora < h && talent < h
                    && mora >= talent) 
                type = 3;
             else 
                type = 4;
        }
        public void printInfo() {
            System.out.println(this.id + " " + this.mora + " " + this.talent);
        }
        //重写排序方法,按照格式排序
        public int compareTo(Person p) {
            if (this.type == p.type) {
                if (this.score == p.score) {
                    if (this.mora == p.mora) 
                        return (this.id - p.id);
                    return (p.mora - this.mora);
                }
                return (p.score - this.score);
            }
            return (this.type - p.type);
        }
    }
    public static void main(String[] args) throws Exception {
    //BufferredReader优化输入速度,结果还是超时了= = 
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String str = br.readLine();
        String[] da = str.split(" ");
        int N = Integer.parseInt(da[0]);
        int l = Integer.parseInt(da[1]);
        int h = Integer.parseInt(da[2]);
        List<Person> PList = new ArrayList<>();
        for (int i = 0; i < N; i++) {
            String line = br.readLine();
            String[] cur = line.split(" ");
            int idtemp = Integer.parseInt(cur[0]);
            int mora = Integer.parseInt(cur[1]);
            int talent = Integer.parseInt(cur[2]);
            Person Person = new Person(idtemp, mora, talent,h);
            Person.id = idtemp;
            Person.mora = mora;
            Person.talent = talent;
            if (mora >= l && talent >= l) 
                PList.add(Person);
        }
        System.out.println(PList.size());
        Collections.sort(PList);
        for (Person Person : PList) 
            Person.printInfo();
    }
}

Java天生的慢,这题Java会超时的,用C++差不多同样的算法,就过了= =。
哎,陈越姥姥什么时候能优化下PAT Java的用时限制。

C++大发好

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
struct Student{
	string numb;
	int De;
	int Cai;
};
bool cmp(Student a,Student b){//格式输出
	if( a.De+a.Cai != b.Cai+b.De) return  a.De+a.Cai > b.Cai+b.De;//先比总分  降序
	else if(a.De != b.De ) return a.De>b.De;//总分相同,再比德分        降序
	else return a.numb<b.numb;//总分,德分都相同,比准考证的字典序       升序
}
int main()
{
	vector<Student > s[4];//vector搭配数组,和二维数组有些类似
	int n,di,gao,d,c;
	string numb; 
	cin>>n>>di>>gao;
	int sum=n; 
	for(int i=0;i<n;i++){
		cin>>numb>>d>>c;
		Student t = {numb,d,c};//numb,d,c都打包进结构体t
		if(d>=gao && c>=gao)//第一类考生
		    s[0].push_back(t);
		else if(d>=gao && c>=di)//第二类
		    s[1].push_back(t);
		else if( d>=c && d>=di && c>=di)//第三类
		    s[2].push_back(t);
		else if(d<c && d>=di && c>=di)//第四类
		    s[3].push_back(t);
		else sum--;//没过线的考生,sum用来记录过线的考生总数 
	}
	cout<<sum<<endl;
	for(int i=0;i<4;i++){
		sort(s[i].begin(),s[i].end(),cmp);//按照事先自定义的cmp规则排序。
		for(int j=0;j<s[i].size();j++)
			cout<<s[i][j].numb<<" "<<s[i][j].De<<" "<<s[i][j].Cai<<'\n';//输出,用'\n'而不用endl避免超时 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值