美丽的蛇形方阵

蛇形填数

在n×n方阵里填入1,2,…,n×n,要求填成蛇形。例如,n=4时方阵为:

   1   2   3   4

  12  13  14   5

  11  16  15   6

  10   9   8   7

为了美化效果,我们设置每个数宽度为4,填充符号为*。先输入n值,n≤10。

【样例输入】

4

【样例输出】

***1***2***3***4

**12**13**14***5

**11**16**15***6

**10***9***8***7

#include  <iostream>
#include  <iomanip>
#define  X  10
#include<cstring>
using  namespace  std; 
int a[X][X];
int main()
{
	int n, x, y, tot = 0;
	cin >> n;
	memset(a, 0, sizeof(a));
	tot = a[x = 0][y = 0] = 1;
	while (tot < n * n)
	{	
		while (y + 1 < n && !a[x][y + 1])
			a[x][++y] = ++tot;
		while (x + 1 < n && !a[x + 1][y])
			a[++x][y] = ++tot;
		while (y - 1 >= 0 && !a[x][y - 1])
			a[x][--y] = ++tot;
		while (x - 1 >= 0 && !a[x - 1][y])
			a[--x][y] = ++tot;
	}
	for (x = 0; x < n; x++)
	{
		for (y = 0; y < n; y++)
			cout << setw(4)<<setfill('*')<<a[x][y];
		cout << endl;
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值