高精度 A - A + B Problem II

题目
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
利用字符来扩大数字的范围

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<math.h> 
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
	
	int n,t;
	cin>>n;
	for(t=1;t<=n;t++)
	{
		char a[1111],b[1111];
		int c[1111];
		cin>>a>>b;
		int i,j,k=0;
		int m=0;
		for(i=strlen(a)-1,j=strlen(b)-1;i>=0&&j>=0;i--,j--)
		{
			int p=(a[i]-'0')+(b[j]-'0')+m;
			m=p/10;
			c[k++]=p%10;
		}
		while(i>=0)
		{
			int p=(a[i]-'0')+m;
			m=p/10;
			c[k++]=p%10;
			i--;
		}
		while(j>=0)
		{
			int p=(b[j]-'0')+m;
			m=p/10;
			c[k++]=p%10;
			j--;	
		}
		if(m)
		{
			c[k++]=m;
		}
		printf("Case %d:\n",t);
		cout<<a<<' '<<'+'<<' '<<b<<' '<<'='<<' ';
		for(int i=k-1;i>=0;i--)
			cout<<c[i];
		printf("\n"); 
		if(t!=n)printf("\n"); 
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值