BFS B - 迷宫问题

题目
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
bfs迷宫问题,设定四个方向从一点开始不断移动,并判断下一个位置是否会出界是否不满足条件。如果都满足就记录当前位置开始走下一步,如果某一步不满足就重复上一个地点的其他方向。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<cstdio>
#include<vector>
#include<set>
#include<cstring>
#include<cstdlib>
#include <time.h>
#include<stack>
using namespace std;
const int maxn=1e3+10;
int mp[10][10],vis[10][10];
int dx[4]={1,-1,0,0},dy[4]={0,0,-1,1};
struct node{
    int x,y;
    node(int xx=0,int yy=0){
        x=xx;
        y=yy;
    }
};
node pre[10][10];
void BFS(){
    queue<node>qu;
    qu.push(node(1,1));
    vis[1][1]=1;
    while(!qu.empty()){
        node now=qu.front();
        qu.pop();
        if(now.y==5&&now.x==5) return;
        for(int i=0;i<4;i++){
            int tx=now.x+dx[i];
            int ty=now.y+dy[i];
            if(tx>5||tx<1||ty>5||ty<1)
                continue;
            if(vis[tx][ty]||mp[tx][ty]==1)
                continue;
            qu.push(node(tx,ty));
            vis[tx][ty]=1;
            pre[tx][ty]=now;
        }
    }
}
void output(int x,int y){
    if(x==1&&y==1){
        printf("%d %d\n",x-1,y-1);
        return;
    }
    node tmp=pre[x][y];
    output(tmp.x,tmp.y);
    printf("%d %d\n",x-1,y-1);
}
int main(){
    for(int i=1;i<=5;i++){
        for(int j=1;j<=5;j++){
            scanf("%d",&mp[i][j]);
        }
    }
    BFS();
    output(5,5);
    system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值