矩阵快速幂 K - A Simple Math Problem

Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
Output
For each case, output f(k) % m in one line.
Sample Input
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0
Sample Output
45
104

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<cstdio>
#include<vector>
#include<set>
#include<cstring>
#include<cstdlib>
#include<time.h>
#include<stack>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=100;
typedef long long ll;
ll mod;
struct mat{
    ll m[maxn][maxn];
}ans,a;//结果矩阵 输入矩阵
ll mode(ll a,ll b){
    ll sum=1;
    a=a%mod;
    while(b){
        if(b&1)
            sum=(sum*a)%mod;
        b/=2;
        a=(a*a)%mod;
    }
    return sum;
}//快速幂
ll inv(ll a,ll b){
    return(a*mode(b,mod-2))%mod;
}//逆元
ll gcd(ll a, ll b) {
	return b?gcd(b, a%b):a;
}//a,b最大公因数
ll exgcd(ll a,ll b,ll &x,ll &y){
    if(b==0){
        x=1;y=0;
        return a;
    }
    int r=exgcd(b,a%b,x,y);
    int temp=y;
    y=x-(a/b)*y;
    x=temp;
    return r;
}//ax+by=d的一组解
mat mul(mat a,mat b,int n){
    mat c;
    memset(c.m,0,sizeof(c.m));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            for(int k=1;k<=n;k++)
                c.m[i][j]=(c.m[i][j]+(a.m[i][k]*b.m[k][j])%mod)%mod;
    return c;
}//矩阵a*b 大小为n
mat _power(mat a,int b,int n){
    memset(ans.m,0,sizeof(ans.m));
    for(int i=1;i<=n;i++)
        ans.m[i][i]=1;
    while(b){
        if(b&1)
            ans=mul(a,ans,n);
        a=mul(a,a,n);
        b>>=1;
    }
    return ans;
}//矩阵a^b
int main()
{
    ll k,m;
    int b[11];
    for(int i=1;i<=10;i++)
        b[i]=i;
    while(scanf("%lld%lld",&k,&m)!=EOF){
        mod=m;
        memset(a.m,0,sizeof(a.m));
        for(int i=1;i<=10;i++)
            scanf("%lld",&a.m[1][i]);
        for(int i=2;i<=10;i++)
            a.m[i][i-1]=1;
        if(k<10) printf("%lld\n",k%mod);
        else{
            ans=_power(a,k-9,10);
             ll sum=0;
        for(int i=1;i<=10;i++)
            sum+=ans.m[1][i]*(10-i)%m;
        printf("%lld\n",sum%m);
        }
    }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值