Problem B. Perfect Numbers(完美数)

Problem B. Perfect Numbers
描述

We consider a positive integer perfect, if and only if it is equal to the sum of its positive divisors
less than itself. For example, 6 is perfect because 6 = 1 + 2 + 3.
Could you write a program to determine if a given number is perfect or not?

输入
The first line of the input is T(1 ≤ T ≤ 100), which stands for the number of test cases you need
to solve.
Each test case contains a line with a positive integer N (2 ≤ N ≤ 10 5 ).

输出
For each test case, print the case number and determine whether or not the number is perfect. If
the number is perfect, display the sum of its positive divisors less than itself. The ordering of the
terms of the sum must be in ascending order. If a number is not perfect, print “Not perfect.”.

输入样例 1

3
6
8
28
输出样例 1

Case 1: 6 = 1 + 2 + 3
Case 2: Not perfect.
Case 3: 28 = 1 + 2 + 4 + 7 + 14
提示

来源

2018上海

题目大意:给出一个正整数,判断它是不是完美数。完美数定义:如果一个正整数N的所有因子之和等于N,那么N就是一个完美数字。

注意一下输出格式之间的空格就行

#include<bits/stdc++.h>
using namespace std;
int a[100000];
int main()
{
    int t;
    cin>>t;
    int num=0;
    while(t--)
    {
        num++;
        int n,s=0;
        cin>>n;
        int i,j;
        for(i=1,j=0;i<=n/2;i++)
        {
            if(n%i==0)
            {
                a[j]=i;
                s=s+i;
                j++;
            }
        }
        if(s==n)
        {
           printf("Case %d: %d = ",num,n);
           for(i=0;i<j-1;i++)
            printf("%d + ",a[i]);
           if(i=j-1)printf("%d\n",a[j-1]);
        }
        else
            printf("Case %d: Not perfect.\n",num);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值