题目描述
采用除留余数法(H(key)=key %n)建立长度为n的哈希表,处理冲突用链地址法。建立链表的时候采用尾插法。
输入
第一行为哈西表的长度m;
第二行为关键字的个数n;
第三行为关键字集合;
第四行为要查找的数据。
输出
如果查找成功,输出该关键字所在哈希表中的地址和比较次数;如果查找不成功,输出-1。
样例输入
13
13
16 74 60 43 54 90 46 31 29 88 77 78 79
16
样例输出
3,1
代码实现:
#include<stdio.h>
#include< iostream>
#include<string.h>
using namespace std;
#define Max 100
typedef struct A{
int data;
struct A* next;
}hash;//定义哈希表结点
hash *array[Max];//哈希表数组
int n1,n2;
void serch(int s)//查找
{
int t=s%n1;
hash *w;
w=array[t];
int count=0;//计数
while(w!=NULL&&w->data!=s)
{
count++;
w=w->next;
}
if(w==NULL)
{
printf("-1");
}
else
{
printf("%d,%d",t,count);
}
}
void create()
{
hash *t;
int i,j;
for(i=0;i<n1;i++) array[i]=NULL;
for(i=0;i<n1;i++)//尾插法
{
t=new hash;
scanf("%d",&t->data);
j=t->data%n1;
t->next=array[j]; //将t结点插入到ht[j]之后;
array[j]=t;
}
}
int main()
{
int s;
cin>>n1;
cin>>n2;
create();
//cout<<“创建完成”<<endl;
cin>>s;
serch(s);
}