问题 A: Rescue The Princess

问题 A: Rescue The Princess
时间限制: 1 Sec 内存限制: 128 MB
题目描述
Several days ago, a beast caught a beautiful princess and the princess was put in prison. To rescue the princess, a prince who wanted to marry the princess set out immediately. Yet, the beast set a maze. Only if the prince find out the maze’s exit can he save the princess.
Now, here comes the problem. The maze is a dimensional plane. The beast is smart, and he hidden the princess snugly. He marked two coordinates of an equilateral triangle in the maze. The two marked coordinates are A(x1,y1) and B(x2,y2). The third coordinate C(x3,y3) is the maze’s exit. If the prince can find out the exit, he can save the princess. After the prince comes into the maze, he finds out the A(x1,y1) and B(x2,y2), but he doesn’t know where the C(x3,y3) is. The prince need your help. Can you calculate the C(x3,y3) and tell him?
输入
The first line is an integer T(1 <= T <= 100) which is the number of test cases. T test cases follow. Each test case contains two coordinates A(x1,y1) and B(x2,y2), described by four floating-point numbers x1, y1, x2, y2 ( |x1|, |y1|, |x2|, |y2| <= 1000.0).
Please notice that A(x1,y1) and B(x2,y2) and C(x3,y3) are in an anticlockwise direction from the equilateral triangle. And coordinates A(x1,y1) and B(x2,y2) are given by anticlockwise.
输出
For each test case, you should output the coordinate of C(x3,y3), the result should be rounded to 2 decimal places in a line.

样例输入 Copy
4
-100.00 0.00 0.00 0.00
0.00 0.00 0.00 100.00
0.00 0.00 100.00 100.00
1.00 0.00 1.866 0.50
样例输出 Copy
(-50.00,86.60)
(-86.60,50.00)
(-36.60,136.60)
(1.00,1.00)

这题需要灵活的想到坐标可以用旋转矩阵来求解。用坐标法实在是太麻烦了,特判n次/狗头
点击这里查看旋转矩阵的百度百科

这里直接放上对二卫平面上的点进行旋转的旋转矩阵公式
在这里插入图片描述
因为这道题仅是对点B绕着A点逆时针旋转60度,所以,将 θ \theta θ = 60度带入即可。

#include <iostream>
#include <cmath>
 
using namespace std;
 
int t;
 
int main(){
    cin >> t;
     
    double a = 1.0 / 2, b = sqrt(3) / 2;
    while (t -- ){
        double x1, y1, x2, y2;
        cin >> x1 >> y1 >> x2 >> y2;
         
        x2 -= x1; y2 -= y1;//将(x1,y1)作为原点,则(x2,y2)需要改动坐标值
        double x = a * x2 - b * y2;
        double y = b * x2 + a * y2;
         
        printf("(%.2lf,%.2lf)\n", x + x1, y + y1);//将(0,0)作为原点,将(x1,y1)还回去
    }
     
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值