Fibsieve`s Fantabulous Birthday LightOJ - 1008 数学

该博客介绍了一个关于棋盘上灯光按特定顺序闪烁的问题,给定一个大时间,需要找出对应点亮的格子坐标。博主通过观察和分析给出了规律:对于时间$s$,其对应的坐标$x$和$y$可以通过开根号得到近似值$n$,再根据奇偶性调整。代码中展示了如何根据这个规律解决此问题。
摘要由CSDN通过智能技术生成

Fibsieve had a fantabulous (yes, it’s an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

在这里插入图片描述
(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input
Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output
For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input
3

8

20

25

Sample Output
Case 1: 2 3

Case 2: 5 4

Case 3: 1 5

题意

首先给你一个图,表示对应时间亮起的规律,
然后给你一个大的时间,让你看它对应的坐标是什么

思路

根据图推出规律即可
假设(n,n)是斜线上的坐标,
它的数是n*n-n+1
然后对于偶数左减,下增
对于奇数左增,下减
开根号给的数。即可知道它的坐标大致在n-1 – n之间,这里n是开根号向下取整的数

具体看代码

Code

#include<bits/stdc++.h>
using namespace std;
const int M=1e4+10;
typedef long long ll;

ll t,s;
int main()
{
    ios::sync_with_stdio(0);
    cin>>t;
    ll k=1;
    while(t--)
    {
        cin>>s;
        ll x,y;
        ll ss=sqrt(s);
        if(ss*ss!=s)
        {
            ll m=ss+1;
            ll tmp=m*m-m+1;
            x=y=m;
            if(m%2==0)
            {
                if(s>tmp)
                {
                    while(s!=tmp)
                    {
                        tmp++;
                        y--;
                    }
                }
                else if(s<tmp)
                {
                    while(s!=tmp)
                    {
                        tmp--;
                        x--;
                    }
                }
            }
            else
            {
                if(s>tmp)
                {
                    while(s!=tmp)
                    {
                        tmp++;
                        x--;
                    }
                }
                else if(s<tmp)
                {
                    while(s!=tmp)
                    {
                        tmp--;
                        y--;
                    }
                }
            }
            cout<<"Case "<<k++<<": "<<x<<" "<<y<<endl;
        }
        else
        {
            if(ss%2==0)
                cout<<"Case "<<k++<<": "<<ss<<" "<<"1"<<endl;
            else
                cout<<"Case "<<k++<<": "<<"1"<<" "<<ss<<endl;
        }


    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值