hdu4282 A very hard mathematic problem(二分)

Haoren is very good at solving mathematic problems. Today he is working a problem like this:
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
   X^Z + Y^Z + XYZ = K
  where K is another given integer.
  Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
  Now, it’s your turn.
Input
  There are multiple test cases.
  For each case, there is only one integer K (0 < K < 2^31) in a line.
  K = 0 implies the end of input.
  
Output
  Output the total number of solutions in a line for each test case.
Sample Input
9
53
6
0
Sample Output
1
1
0

Hint
9 = 1^2 + 2^2 + 1 * 2 * 2
53 = 2^3 + 3^3 + 2 * 3 * 3

分析:

X^Z + Y^Z + XYZ = K (X<Y,Z>1 0<K<2^31)已知k,计算符合条件的(X,Y,Z)的数量
枚举X,Y,Z,三层循环会超时,所以枚举X,Z,判断Y是否存在。先预处理出X^Z,由数据的范围可以得知1<X<50000,2<Z<31。

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string>
#include<string.h>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;
#define ll long long
#define eps 1e-8
#define pi acos(-1)
const int N = 5e4+10;
ll f[N][40];
void ff()//预处理出f[i][j]:i^j 
{
	for(int i=1;i<=50000;i++)
	{
		f[i][1]=i;
		for(int j=2;j<=31;j++)
		{
			f[i][j]=f[i][j-1]*i;
			if(f[i][j]>2147483648LL)//2^31 要加LL 
			break;
		}
	}
}
int check(ll p,int x,int z)//判断当前x,z的情况下,y是否存在 
{
	int l=x+1,r=50000;//因为题意中提到y>x 
	while(l<=r)
	{
		int mid=(l+r)/2;
		if(f[mid][z]==0) //当前mid^z已经超过了2^31 
		{
			r=mid-1;
		}
		else if(f[mid][z]+mid*x*z<p) l=mid+1;
		else if(f[mid][z]+mid*x*z>p) r=mid-1;
		else return 1;
	}
	return 0;
}
int main()
{
	ff();
	ll k;
	while(scanf("%lld",&k))
	{
		if(k==0) break;
		ll sum=0;
		for(int i=1;i<=50000&&i<=k;i++)//枚举x 
		{
			for(int j=2;j<=31;j++)//枚举z 
			{
				if(f[i][j]==0) break;//i^j 已经大于2^31 
				ll x=k-f[i][j];
				if(x-i*j<=0) break;  
				if(check(x,i,j)) sum++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值