Kickdown UVA - 1588

A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown — an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the gears. Now they want to perform some experiments to prove their findings.

The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h. Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).

There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.

The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to find the minimal length of the stripe which is enough for cutting both sections simultaneously.

Input

The input file contains several test cases, each of them as described below.

There are two lines in the input, each contains a string to describe a section. The first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sections can not be flipped or rotated.

Each string is non-empty and its length does not exceed 100.

Output

For each test case, write to the output a line containing a single integer number — the minimal length of the stripe required to cut off given sections.

Sample Input

2112112112
2212112
12121212
21212121
2211221122
21212

Sample Output

10
8
15

HINT

相当于两个滑块,一个不懂一个动,求最小长度。下面的代码可以更简洁一点,就是把重复的地方封装成函数,可以省不少代码量。

Accepted

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int main()
{
	char a[101];
	char b[101];
	char c[201];
	while (scanf("%s%s", a, b) != EOF)
	{
		int lena = strlen(a);
		int lenb = strlen(b);
		int min = lena+lenb;
		
		for (int i = 0;i <= lena; i++)
		{
			int flag = 0;
			memset(c, '\0', sizeof(c));
			strcpy(c, a);
			for (int j = 0;j < lenb;j++)
			{
				if (c[j + lena - i] != '\0')
				{
					c[j + lena - i] += b[j] - '0';
					if (c[j + lena - i]  > '3')
					{
						flag = 1;break;
					}
				}
				else c[j + lena - i] = b[j];
			}
			if (!flag)min = strlen(c) < min ? strlen(c) : min;
		}
		for (int i = 0;i <= lenb;i++)
		{
			int flag = 0;
			memset(c, '\0', sizeof(c));
			strcpy(c, b);
			for (int j = 0;j < lena;j++)
			{
				if (c[j + lenb - i] != '\0')
				{
					c[j + lenb - i] += a[j] - '0';
					if (c[j + lenb - i] > '3')
					{
						flag = 1;break;
					}
				}
				else c[j + lenb - i] = a[j];
			}
			if (!flag)min = strlen(c) < min ? strlen(c) : min;
		}
		printf("%d\n",min);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值