S-Trees UVA - 712

  A Strange Tree (S-tree) over the variable set Xn = {x1*,x2,…,xn*} is a binary tree representing a Boolean function f : {0*,1}n → {0,*1}. Each path of the S-tree begins at the root node and consists of n + 1 nodes. Each of the S-tree’s nodes has a depth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less than n are called non-terminal nodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminal node is marked with some variable xi from the variable set Xn. All non-terminal nodes with the same depth are marked with the same variable, and non-terminal nodes with different depth are marked with different variables. So, there is a unique variable xi1 corresponding to the root, a unique variable xi2 corresponding to the nodes with depth 1, and so on. The sequence of the variables xi1, xi2, , xi**n is called the variable ordering. The nodes having depth n are called terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0’s and 1’s on terminal nodes are sufficient to completely describe an S-tree.
在这里插入图片描述

  As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables x1, x2, , xn, then it is quite simple to find out what f(x1*,x2,…,xn*) is: start with the root. Now repeat the following: if the node you are at is labelled with a variable xi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the function.

Figure 1: S-trees for the function x1∧ (x2∨ x3)

  On the picture, two S-trees representing the same Boolean function, f(x1*,x2,x3) = x1∧ (x2∨ x3), are shown. For the left tree, the variable ordering is x1,x2,x3, and for the right tree it is x3,x1,x*2.

The values of the variables x1, x2, , xn, are given as a Variable Values Assignment (VVA)

(x1 = b1*,x2 = b2,…,xn* = bn)

  with b1*,b2,…,bn* ∈ {0*,1}. For instance, (x1 = 1, x2 = 1, x3 = 0) would be a valid VVA for n = 3, resulting for the sample function above in the value f(1,1,*0) = 1 ∧ (1 ∨ 0) = 1. The corresponding paths are shown bold in the picture.

Your task is to write a program which takes an S-tree and some VVAs and computes f(x1*,x2,…,xn*) as described above.

Input

  The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line containing a single integer n, 1 ≤ n ≤ 7, the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line is xi1 xi2 … xi**n. (There will be exactly n different space-separated strings). So, for n = 3 and the variable ordering x3, x1, x2, this line would look as follows: x3 x1 x2

  In the next line the distribution of 0’s and 1’s over the terminal nodes is given. There will be exactly 2n characters (each of which can be ‘0’ or ‘1’), followed by the new-line character. The characters are given in the order in which they appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node.

The next line contains a single integer m, the number of VVAs, followed by m lines describing them. Each of the m lines contains exactly n characters (each of which can be ‘0’ or ‘1’), followed by a new-line character. Regardless of the variable ordering of the S-tree, the first character always describes the value of x1, the second character describes the value of x2, and so on. So, the line

110

 corresponds to the VVA (x1 = 1, x2 = 1, x3 = 0).

The input is terminated by a test case starting with n = 0. This test case should not be processed.

Output

  For each S-tree, output the line ‘S-Tree #j:’, where j is the number of the S-tree. Then print a line that contains the value of f(x1*,x2,…,xn*) for each of the given m VVAs, where f is the function defined by the S-tree.

Output a blank line after each test case.

Sample Input

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0

Sample Output

S-Tree #1:
0011

S-Tree #2:
0011

HINT

理解这个题意需要知道以下几点:

  1. 二叉树为满二叉树,编号为k的结点必须有两个孩子,左节点的编号为2k,右节点的编号为2k+1.
  2. 每一层都对应一个变量,比如第一、二、三层对应变量分别为 x2,x1,x3。
  3. 二叉树最大右7层,利用暑促足以存储满二叉树。
  4. 计算VVA时,输入的每一个字符串都是从对应的x1,x2,x3…的顺序展开。即:第一个字符总是描述x1的值,第二个字符描述x2的值,以此类推。因此,第110行对应于VVA(x1= 1,x2= 1,x3= 0)。
  5. 输出VAA的时候要输出连个回车我,也即是没两个样例有一个空行,包括最后一行。

解决思路:

  由于每一等的变量的编号可能发生变化,因此使用输出来存储对应的变量编号,如第一层为x3,则数组x[0]=3。然后根据输入的串一直计算到叶子结点的位置,保存,输出。

Accepted

#include<bits/stdc++.h>
using namespace std;

int main() {
	int deep, num,sum,temp,tree=1;
	string s,vva,result;
	vector<int>x;
	while (cin >> deep && deep) {
		x.clear();result.clear();temp = 1;
		sum = pow(2,deep);
		for (int i = 0;i < deep;i++) {
			cin >> s;
			x.push_back(((int)(s.back() - '0')));
		}
		cin >> s >> num;
		for (int i = 0;i < num;i++) {
			cin >> vva;
			for (int j=0;j < vva.length();j++) {
				if (vva[x[j]-1] == '1')temp = 2 * temp + 1;
				else if (vva[x[j]-1] == '0')temp = 2 * temp;
			}
			result.push_back(s[temp - sum]);temp = 1;
		}
		cout << "S-Tree #" << tree++ << ':' << endl << result << endl << endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值