HDU1062 Text Reverse(栈)数据结构

HDU1062 Text Reverse(栈 c++)

题目链接: Text Reverse
题目大意: Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.(翻转字符串)
样例输入:

3
olleh !dlrow
m'I morf .udh
I ekil .mca

样例输出:

hello world!
I'm from hdu.
I like acm.

题解思路:

代码如下:

#include<bits/stdc++.h>

using namespace std;
typedef long long ll;

int ans;
string str;
int m, n;
stack<char> a;
char ch;

void slove()
{

}

int main()
{
    cin >> m;
    getchar();
    while(m--){
        while(1){
        
            ch = getchar();
            if(ch == ' ' || ch == '\n' || ch == EOF){
                while(!a.empty()){
                    cout << a.top();
                    a.pop();
                }
                
                if(ch == ' '){
                    cout <<" ";
                }
            }
            else{
                a.push(ch);
            }

            if(ch == '\n' || ch == EOF){
                break;
            }
        }
        
        cout <<"\n";
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值