实验四 类与对象的方法的权限控制

public String toString() {
 		String result = String.format("name=%s,id=%s,score=%d",name,id,score);
 		return result;
    }

public String toString() {
		return "a=" + a + ",b=" + b + ",c=" + c;
	}

1. 根据Student类的描述以及输出要求,完成代码空白处的填写。

【问题描述】定义Student类,包含三个私有属性:name、id、score,根据输出结果,填写程序的空白处。
构造方法中,如果输入的分数不在0~100之间,则对score属性赋值为0。
在对score属性赋值的set方法中,如果给的值不在0~100之间,则给出错误信息,并且不对score进行修改。
【输入形式】
从键盘输入姓名、学号、成绩。
【输出形式】
输出学生的相关信息。
【样例输入①】
zhangsan
201801001
80
【样例输出①】
name=zhangsan,id=201801001,score=80
score input error
name=zhangsan,id=201801001,score=80
【样例输入②】
lisi
201801002
40
【样例输出②】
name=lisi,id=201801002,score=40
name=lisi,id=201801002,score=90
【样例输入③】
def
201801005
-10
【样例输出③】
name=def,id=201801005,score=0
name=def,id=201801005,score=40

import java.util.Scanner;

public class Student {
	 private String name, id;
     private int score;
     
     //自己编写部分
     public Student(String name,String id,int score) {
    	 if(score<=100 && score>=0) {
    		 this.name = name;
    		 this.id = id;
    		 this.score = score;
    	 }else {
    		 this.name = name;
    		 this.id = id;
    		 this.score=0;
    	 }
     }
     public void setScore(int sc){
	     if(sc<=100 && sc>=0) {
	    	 score=sc;
	     }else {
	    	 System.out.println("score input error");
	     }
     }
    
     public String toString() {
 		String result = String.format("name=%s,id=%s,score=%d",name,id,score);
 		return result;
 	 }
     
     public static void main(String[] args) {
         Scanner in = new Scanner(System.in);
         String n, s;
         int sc;
         n = in.nextLine();
         s = in.nextLine();
         sc = in.nextInt();
         Student stu = new Student(n, s, sc);
         System.out.println(stu);
         stu.setScore(sc + 50);
         System.out.println(stu);
    }
}

2. 根据输入的a、b、c,计算三角形面积和周长。根据程序上下文以及输入输出样例,填写程序空白,使程序完整。

【问题描述】
输入三角形的三边长,计算面积和周长。
类中有构造方法、关于属性的set、get方法、计算面积和周长的方法。如果输入的边长不能构成三角形,则对象会拒绝接受该值,并输出相应的错误信息。
如果构造方法中提供的三边不能构成三角形,则三边都赋值为0。
根据已有源代码和输出结果,填写代码空白处,使程序完整。
【输入形式】
三角形的三边长度。
【输出形式】
三角形的面积和周长,或者还包含错误信息。
【样例输入①】
3 4 5
【样例输出①】
perimeter=12.0
area=6.0
a=3.0,b=4.0,c=5.0
a=6.0,b=6.0,c=6.0
a input error
a=6.0,b=6.0,c=6.0
b input error
a=6.0,b=6.0,c=6.0
c input error
a=6.0,b=6.0,c=6.0
【样例输入②】
100 120 150
【样例输出②】
perimeter=370.0
area=5981.168364124187
a=100.0,b=120.0,c=150.0
a=103.0,b=122.0,c=151.0
a=123.0,b=122.0,c=151.0
a=123.0,b=142.0,c=151.0
a=123.0,b=142.0,c=171.0
【样例输入③】
1 2 3
【样例输出③】
perimeter=0.0
area=0.0
a=0.0,b=0.0,c=0.0
a b c input error
a=0.0,b=0.0,c=0.0
a input error
a=0.0,b=0.0,c=0.0
b input error
a=0.0,b=0.0,c=0.0
c input error
a=0.0,b=0.0,c=0.0

import java.util.Scanner;

public class Triangle {
    private double a,b,c;
    
    // 以下均为需要自己编写部分,直至主函数处
    
    //构造方法,如果三边不能构成三角形,a,b,c都赋值为0
	public Triangle(double a,double b,double c){
		if(isTriangle(a, b, c)){
			this.a = a;
			this.b = b;
			this.c = c;
		}else{
			this.a = 0;
			this.b = 0;
			this.c = 0;
		}
	}
	
	public void setSide(double x, double y, double z) {
		if (isTriangle(x, y, z)) {
			this.a = x;
			this.b = y;
			this.c = z;
		} else {
			this.a = 0;
			this.b = 0;
			this.c = 0;
		}
	}

	//关于属性a,b,c的set、get方法
	//加入set()做条件判断,如果输入的边长不能构成三角形,则对象会拒绝接受该值,并输出相应的错误信息。
	public double getA() {
		return a;
	}

	public void setA(double a) {
		if (isTriangle(a, b, c)) {
			this.a = a;
		} else {
			System.out.println("a input error");
		}
	}

	public double getB() {
		return b;
	}

	public void setB(double b) {
		if (isTriangle(a, b, c)) {
			this.b = b;
		} else {
			System.out.println("b input error");
		}
	}

	public double getC() {
		return c;
	}

	public void setC(double c) {
		if (isTriangle(a, b, c)) {
			this.c = c;
		} else {
			System.out.println("c input error");
		}
	}

	public boolean isTriangle(double a,double b,double c) {//判断输入的三边能否构成三角形
		return a+b>c && a+c>b && b+c>a;
	}
	
	public double getArea() {//利用海伦公式计算三角形面积
		double p = getPerimeter() / 2;//半径
		return Math.sqrt(p * (p - getA()) * (p - getB()) * (p - getC()));
	}
	
	public double getPerimeter() {//计算三角形周长
		return getA() + getB() + getC();

	}
	
	public String toString() {
		return "a=" + a + ",b=" + b + ",c=" + c;
	}

    public static void main(String args[]) {
        Scanner in = new Scanner(System.in);
        double x = in.nextDouble();
        double y = in.nextDouble();
        double z = in.nextDouble();
        Triangle t = new Triangle(x,y,z);
        System.out.println("perimeter=" + t.getPerimeter());
        System.out.println("area=" + t.getArea());
        System.out.println(t);
        t.setSide(t.getA() + 3,t.getB() + 2,t.getC() + 1);
        System.out.println(t);
        t.setA(t.getA() + 20);
        System.out.println(t);
        t.setB(t.getB() + 20);
        System.out.println(t);
        t.setC(t.getC() + 20);
        System.out.println(t);
        in.close();
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值