Eight

 The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:


 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x


where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:


 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->


The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output
You will print to standard output either the word ``unsolvable’’, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
Sample Input

2  3  4  1  5  x  7  6  8

Sample Output

ullddrurdllurdruldr
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<iostream>
using namespace std;
const int MAXN=400000;
bool has[MAXN];
int fac[9] = {1, 1, 2, 6, 24, 120, 720, 5040, 40320};
int dx[] = {-1, 0, 1, 0};
int dy[] = {0, -1, 0, 1};
int last[MAXN];
short int mov[MAXN];
struct State{
    short int s[9];
    short int pos;
    int hash;
}ini;
queue<State> q;

int Hash(short int *s)
{
    int res=0;
    for(int i=0;i<8;i++)
    {
        int cnt=0;
        for(int j=i+1;j<9;j++)
            if(s[i]>s[j])
            cnt++;
        res +=cnt*fac[8-i];
    }
    return res;
}
int cal_pos(int pos,int i)
{
    int nx=pos/3+dx[i],ny=pos%3+dy[i];
    if(nx<0||nx>2||ny<0||ny>2)
        return -1;
    return nx*3+ny;
}
void BFS()
{
    State target;
    for(int i=0;i<9;i++)
        target.s[i] = i+1;
    target.pos=8;
    target.hash=0;
    has[0]=1;
    q.push(target);
    while(!q.empty())
    {
        State ha = q.front();
        q.pop();
        State tmp;
        for(int i=0;i<4;i++)
        {
            tmp.pos=cal_pos(ha.pos,i);
            if(tmp.pos<0)
                continue;
            for(int j=0;j<9;j++)
            {
                if(j==ha.pos)
                    tmp.s[j]=ha.s[tmp.pos];
                else
                    if(j==tmp.pos)
                        tmp.s[j]=ha.s[ha.pos];
                else tmp.s[j]=ha.s[j];
            }
            tmp.hash = Hash(tmp.s);
            if(has[tmp.hash])
                continue;
            q.push(tmp);
            has[tmp.hash]=1;
            last[tmp.hash]=ha.hash;
            mov[tmp.hash]=i;
        }
    }
}
 void print_path(int x)
 {
     if(x==0)
        return ;
     int i=mov[x];
     if(!i) printf("d");
     else if(i==1)
        printf("r");
     else if(i==2)
        printf("u");
     else
        printf("l");
     print_path(last[x]);
 }
 int main()
 {
     memset(has,0,sizeof(has));
     BFS();
     char tmp;
     while(cin>>tmp)
     {
         if(tmp!='x')
            ini.s[0]=tmp-'0';
         else
         {
             ini.s[0]=9;
             ini.pos=0;
         }
         for(int i=1;i<9;i++)
         {
             cin>>tmp;
             if(tmp=='x')
             {
                 ini.s[i]=9;
                 ini.pos=i;
             }
             else
                ini.s[i]=tmp-'0';

         }
         ini.hash=Hash(ini.s);
         if(!has[ini.hash])
            printf("unsolvable");
        else
            print_path(ini.hash);
        puts("");
              }
        return 0;
 }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值