C/C++ 结构体之时间设计

题目 1049: 结构体之时间设计
时间限制: 1Sec 内存限制: 128MB 提交: 6937 解决: 3962

题目描述
定义一个结构体变量(包括年、月、日)。计算该日在本年中是第几天,注意闰年问题。
输入
年月日
输出
当年第几天
样例输入
2000 12 31
样例输出
366

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    struct time
    { 
        int year;
        int month;
        int day; 
    };
    typedef struct time SJ;
    SJ str;
    cin>>str.year>>str.month>>str.day;
    int xb=0;
    if((str.year%4==0&&str.year%100!=0)||(str.year%400==0))
    {
        xb+=1;
    }
    int cns=0;
    switch(str.month)
    {
        case 1:cns=0;break;
        case 2:cns=31;break;
        case 3:cns=59;break;
        case 4:cns=90;break;
        case 5:cns=120;break;
        case 6:cns=151;break;
        case 7:cns=181;break;
        case 8:cns=212;break;
        case 9:cns=243;break;
        case 10:cns=273;break;
        case 11:cns=304;break;
        case 12:cns=334;break;
    }
    cns=cns+xb+str.day;
    cout<<cns<<endl;
   return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值