1012 The Best Rank(排序)

1012 The Best Rank

0、题目

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

1、大致题意

把考生CMEA(平均分)分别排序,并输出最好的名次;如果名次相同,按照A>C>M>E的顺序输出;如果当前id不存在,输出N/A

2、基本思路

用结构体存储学生的 id、四门成绩、四门排名。然后 sort 大法出击,计算出每科排名。最后遍历得到最后结果。

2.1 坑点 - 并列排名

并列排名应该是 1、1、3、4、5,而不不是 1、1、2、3、4,否则会有一个测试点不过

2.2 四舍五入平均分

平均分是四舍五入的,所以需要按照 +0.5 后取整,保证是四舍五入的(听说不不四舍五入也能通过…)。

a[i].scord[0] = (a[i].scord[1]+a[i].scord[2]+a[i].scord[3])/3.0 + 0.5; //scord是int类型

当然为了方便也可以直接使用 double ,省时省力。

3、AC代码

#include<bits/stdc++.h>
using namespace std;

struct stu {
	int id;
	double score[5];
	int Rank[5];
};
stu student[2005];
int now;
bool cmp(stu a,stu b) { //降序排列
	return a.score[now]>b.score[now];
}
int rank1[1000000][5];
char sco[4]= {'C','M','E','A'};
int main() {
	int n,m;
	cin>>n>>m;
	for(int i=0; i<n; i++) {
		cin>>student[i].id;
		double sum=0;
		for(int j=0; j<3; j++) {
			cin>>student[i].score[j];
			sum+=student[i].score[j];
		}
		student[i].score[3]=sum/3;
	}
	for(now =0; now<4; now++) {
		sort(student,student+n,cmp);
		rank1[student[0].id][now]=1;
		for(int i=1; i<n; i++) { //计算出排名
			if(student[i].score[now]==student[i-1].score[now]) { //并列第一
				rank1[student[i].id][now]=rank1[student[i-1].id][now];
			} else {
				rank1[student[i].id][now]=i+1;
			}
		}
	}
	while(m--) {
		int id;
		cin>>id;
		if(!rank1[id][0]) {
			cout<<"N/A"<<endl;
		} else {
			int k=3; //A > C > M > E
			for(int i=0; i<4; i++) {
				if(rank1[id][i]<rank1[id][k]) {
					k=i;
				}
			}
			cout<<rank1[id][k]<<" "<<sco[k]<<endl;
		}
	}
	return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值