1016 Phone Bills(模拟)

1016 Phone Bills

0、题目

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

1、大致题意

给出24小时的电话费,并给出后台记录的电话记录,给出合理的电话报表

2、基本思路

这道题目主要可以分解为三个问题:

  1. 电话信息 onoff 的匹配,这个只要按照名字从小到大,再按照时间从小到大排序,最后前后两个比较是不是一个 on 一个 off 即可。因为off时间早于 on 的一定是无效的。
  2. 钱的计算问题。有两个方法,一个是以 on 的时间为起点,一分钟一分钟地加到off的时间,每个小时都要加个if;另一个是从柳神那里学来的,就是把所有计费都从月初的 00:00:00:00 开始,客户的实际消费就是 off 的时间减去 on 的时间。
  3. 第一次信息输出时需要带上名字和月份,最后一次输出要有 Total amount。所以这里需要有一个判断。

3、解题过程

0 、1测试点:没有消费的用户不能输出

输入:
CYY 01:02:01:01 on-line
CYY 01:02:01:01 off-line
输出:
CYY 01
01:02:01:01 01:02:01:01 0 $0
Total amount: $0

2测试点:on和off日期不在同一天却在同一个小时

3测试点:on和off日期同一天同一个小时

#include<bits/stdc++.h>
using namespace std;
int rate[25]; //存储24小时内的电话消费,rate【24】存储一天的消费
int N;
typedef struct Phone {
	string name;
	int MM,DD,HH,mm,time; //time用来把所有时间换算成分钟
	int turn;
};

bool cmp(Phone a,Phone b) { //名字从小到大排序,名字相同按时间从小到大
	if(a.name!=b.name) return a.name<b.name;
	return a.time<b.time;
}

double billfromzero(Phone call) { //从月初开始计费,开始与结束时间的话费差就是需要的费用
	double total = rate[call.HH] * call.mm + rate[24] * 60 * call.DD;
	for (int i = 0; i < call.HH; i++) {
		total += rate[i] * 60;
	}
	total /= 100.0;
	return total;
}


int main() {
	for(int i=0; i<24; i++) {
		cin>>rate[i];
		rate[24]+=rate[i];
	}
	cin>>N;
	vector<Phone> P(N);
	for(int i=0; i<N; i++) {
		cin>>P[i].name;
		scanf("%d:%d:%d:%d",&P[i].MM,&P[i].DD,&P[i].HH,&P[i].mm);
		string a;
		cin>>a;
		P[i].turn = (a=="on-line") ? 1:0;//“on-line”为1,“off-line”为0
		P[i].time = P[i].DD*24*60+P[i].HH*60+P[i].mm;//换算成min为单位
	}
	sort(P.begin(),P.end(),cmp);
	map<string,vector<Phone> > m;
	for(int i=1; i<N; i++) {
		if(P[i].name == P[i-1].name&&P[i-1].turn==1&&P[i].turn==0) {
			m[P[i-1].name].push_back(P[i-1]);
			m[P[i-1].name].push_back(P[i]);
		}
	}
	for(auto it : m) {
		vector<Phone> temp = it.second;
		cout<<it.first;
		printf(" %02d\n",temp[0].MM);
		double tol=0;
		for(int i=1; i<temp.size(); i+=2) {
			double money = billfromzero(temp[i])-billfromzero(temp[i-1]);
			printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",temp[i-1].DD,temp[i-1].HH,temp[i-1].mm,temp[i].DD,temp[i].HH,temp[i].mm,temp[i].time-temp[i-1].time,money);
			tol+=money;
		}
		printf("Total amount: $%.2f\n",tol);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值