2021-04-04

本文分享了两个C++程序,用于找出所有满足给定整数N条件下,首位允许为零的五位数对,其中第一个数除以第二个数等于整数N。展示了如何通过枚举和检查数字使用情况来解决此问题,并给出了样例输入输出及解决方案。
摘要由CSDN通过智能技术生成

Division

Time Limit:3000MS Memory Limit:Unknown 64bit IO Format:%lld & %llu
Submit Status

Description

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where . That is,

abcde / fghij =N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input

Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).
Your output should be in the following general form:

xxxxx / xxxxx =N

xxxxx / xxxxx =N

In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions for N.". Separate the output for two different values of N by a blank line.

Sample Input

61
62
0
Sample Output
There are no solutions for 61.

79546 / 01283 = 62
94736 / 01528 = 62

思路

枚举fghij,abcde=fghij*n,判断abcde和fghij是否有重复的数字

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int a[10]={0};
    int fghij=0,abcde=0,n,flat=0;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        int flog=0;
        for (fghij = 1000; fghij <10000 ; ++fghij)
        {
            flat=0;
            memset(a,0, sizeof(a));
            abcde=fghij*n;
            if(abcde>100000)
                continue;
            int b=abcde;
            int f=fghij;
            for(int i=0;i<5;i++)
            {
                a[f%10]++;
                f/=10;
            }
            for(int i=0;i<5;i++)
            {
                a[b%10]++;
                b/=10;
            }
            if(a[f%10]>1||a[b%10]>1)
            {
                flat++;
                continue;
            }
            for(int i=1;i<10;i++)
                if(a[i]>1)
                {
                    flat++;
                    continue;
        }
            if(!flat)
            {
                printf("%05d/%05d=%d\n",abcde,fghij,n);
                flog++;
            }
    }
        if(flog==0)
            printf("There are no solutions for %d.\n",n);
    }
    return 0;
}

集合

#include <bits/stdc++.h>
using namespace std;
bool has=false;
set<int>digits;
bool getDigit(int m,int n)
{
    for (int i = 0; i <5 ; ++i) {
        int digit1=m%10;
        m=m/10;
        int digit2=n%10;
        n=n/10;
        digits.insert(digit1);
        digits.insert(digit2);
    }
    if(m!=0)
        return false;
    else
        return true;
}
int main()
{
    int n,num=0;
    while(true) {
        cin >> n;
        if (n == 0)
            break;
        if(num>0)
            printf("\n");
        num++;
        has = false;
        for (int i = 1000; i < 100000; i++) {
            int j = i * n;
            digits.clear();
            int flag = getDigit(j, i);
            if (!flag)
                break;
            if (digits.size() != 10)
                continue;
            has = true;
            printf("%05d/%05d=%d\n", j, i, n);
        }
        if (!has)
            printf("There are no solutions for %d.\n", n);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值