**软件包xx没有可安装候选**

最近做实验,在ubuntu中安装apt-get install libasound2-dev,发现命令不成功,且显示软件包xx没有可安装候选
然后按照网上给出的方法:sudo apt-get update
后出现:
在这里插入图片描述
然后再用网上的方法:在这里插入图片描述
再sudo apt-get update后发现更新很慢,且有错误
在这里插入图片描述
尝试各种方法后…
再输入命令:apt-get install libasound2-dev,还是原样…

不过,到最后我找到了解决方法:
更换国内源:
先备份:sudo cp /etc/apt/sources.list /etc/apt/sources_init.list
打开文档:sudo gedit /etc/apt/sources.list
把想要的国内源复制进去,保存关闭

更换国内源转自文章:
https://blog.csdn.net/qq_35451572/article/details/79516563

再输入命令:sudo apt-get update
完成后再输入:apt-get install libasound2-dev
就可以安装成功了
在这里插入图片描述

展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 游动-白 设计师: 上身试试
应支付0元
点击重新获取
扫码支付

支付成功即可阅读