JavaA+B

第一周:
仅提供Java简单代码:

标题Problem A: A + B

(Time Limit: 1 Sec Memory Limit: 128 MB)

Description

计算A+B

Input

输入数据有多组。每组输入数据包括两个整数A和B,A和B之间用空格分隔,每组输入占一行。

Output

对于每组输入数据,计算A和B的和并输出,每个输出占一行。

Sample Input Copy

1 5
10 20

Sample Output Copy

6
30

Java代码:

import  java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner input =new Scanner(System.in);
        int a,b;
        while(input.hasNext())
        {
         a=input.nextInt();
         b=input.nextInt();
        System.out.println(a+b);
        }    
    }
}

运行结果:

    Language: Java
    Result: Accepted
    Time:111 ms
    Memory:10144 kb

标题Problem B: A + B

(Time Limit: 1 Sec Memory Limit: 128 MB)

Description

计算A+B

Input

输入数据第一行包含一个整数N,接下来是N行。每行包括两个整数A和B,A和B之间用空格分隔。

Output

对于每组输入数据,计算A和B的和并输出,每个输出占一行。

Sample Input Copy

2
1 5
10 20

Sample Output Copy

6
30

Java代码:

import  java.util.Scanner;

public class  Main{    
    public static void main(String[] args) {
        Scanner input =new Scanner(System.in);
        int a,b,j;
        j=input.nextInt();
        for(int i=1;i<=j;i++)
        {
            a=input.nextInt();
            b=input.nextInt();
            System.out.println(a+b);
        }  
    }
}

运行结果:

    Language: Java
    Result: Accepted
    Time:110 ms
    Memory:10160 kb

标题Problem C: A + B

(Time Limit: 1 Sec Memory Limit: 128 MB)

Description

计算A+B

Input

输入数据有多组。每组输入数据包括两个整数A和B,A和B之间用空格分隔,每组输入占一行。当A和B都是0时输入结束。

Output

对于每组输入数据,计算A和B的和并输出,每个输出占一行。

Sample Input Copy

1 5
10 20
0 0

Sample Output Copy

6
30

Java代码:

import  java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input =new Scanner(System.in);
        int a,b;
        while(input.hasNext())
        {
            a=input.nextInt();
            b=input.nextInt();
            if(a==0&&b==0) 
             {
             break;
             }
            System.out.println(a+b);              
        }
             
    } 
}

运行结果:

    Language: Java
    Result: Accepted
    Time:107 ms
    Memory:10136 kb

标题Problem D: 求和

(Time Limit: 1 Sec Memory Limit: 128 MB)

Description

计算给定整数序列的和。

Input

输入数据有多组。每组输入数据包括一个整数N和N个整数,每个整数之间用空格分隔,每组输入占一行。当N为0时输入结束。

Output

对于每组输入数据,计算N个整数的和并输出,每个输出占一行。

Sample Input Copy

4 1 2 3 4
5 1 2 3 4 5
0

Sample Output Copy

10
15

Java代码:

import  java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input =new Scanner(System.in);
        int a,b,sum;
        while(input.hasNext())       
    	{ 
    	   	
      	sum=0;
      	b=input.nextInt();
        if(b==0)	
        {	
        break;	
        }
    	for(int i=1;i<=b;i++) 
        {
        a=input.nextInt();sum+=a;
        }
		System.out.println(sum);
		
    	}
	}
}

运行结果:

 	Language: Java
    Result: Accepted
    Time:112 ms
    Memory:10172 kb

END

  • 1
    点赞
  • 12
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

美迪的麦柯

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值