HDU1518.Square(剪枝

Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing “yes” if is is possible to form a square; otherwise output “no”.

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

题意:多个数字能否组成正方形?
剪枝:
1.数字和是否能被4整除
2.是否存在大于边长的数字
3.当满足以上情况时,数字们能组成3个边时就能确定一定能组成正方形

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<functional>
#include<iostream>
using namespace std;
int m,a[25],b[25],bian,flag;

void dfs(int sum,int k,int num)
{
    if(flag)
        return;
    if(num==3)
    {
        flag=1;
        return ;
    }
    for(int i=k+1;i<=m;i++)
        if(!b[i]&&!flag&&sum+a[i]<=bian)
        {
            b[i] = 1;
            if(sum+a[i]==bian)
                dfs(0,0,num+1);
            else
                dfs(sum+a[i],i,num);
            b[i] = 0;
        }
}

int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        int sum=0;
        cin>>m;
        for(int i=0;i<m;i++)
        {
            cin>>a[i];
            sum+=a[i];
        }
        sort(a,a+m,greater<int>());//大到小排序
        flag=false;
        if(sum%4==0&&a[0]<=sum/4)
        {
            memset(b,0,sizeof(b));
            bian=sum/4;
            dfs(0,0,0);
        }
        if(flag)
            cout<<"yes\n";
        else
            cout<<"no\n";
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值