Java 编写一个MyPoint类,定义方法输出MyPoint的信息。编写应用程序使用MyPoint。

题目:

【问题描述】

编写一个MyPoint类,该类拥有横、纵坐标两个属性,定义构造方法来初始化类的这些属性,定义方法输出MyPoint的信息。编写应用程序使用MyPoint。

【输入形式】

请输入横坐标(X):

请输入纵坐标(Y):

【输出形式】

你的位置的横坐标(X)为:

你的位置的纵坐标(Y)为:

【输入样例】

Please input the horizontal (X) : 30.5

Please input the ordinate (Y) : 75.6

【输出样例】

Your location of horizontal (X) is : 30.5

Your location of ordinate (Y) is : 75.6

代码:

import java.util.Scanner;
class MyPoint{
	static float x;
	static float y;
	static void Point(){
		System.out.println("Your location of horizontal (X) is :"+x);
		System.out.println("Your location of ordinate (Y) is :"+y);
	}
}
public class Main{
	public static void main(String[] args){
		Scanner in=new Scanner(System.in);
		System.out.println("Please input the horizontal (X) :");
		float x=in.nextFloat();
		System.out.println("Please input the ordinate (Y) :");
		float y=in.nextFloat();
		MyPoint n=new MyPoint();
		MyPoint.x=x;
		MyPoint.y=y;
		MyPoint.Point();
	}
}

  • 2
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

爱犯错的小z

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值