51nod 3191 角谷猜想

题目

角谷猜想的内容是:“对任意的正整数n,若为偶数,则把它除以2;若为奇数,则把它乘以3加1 。经过如此有限次运算后,总可以得到正整数值1 。“
请你编一个程序,根据输入的正整数n,输出每一步运算结果。

输入
输入一个正整数n。
输出
输出若干行,每行一个算式表示计算过程。
数据范围
对于20%的数据,2≤n≤10;
对于100%的数据,2≤n≤100;
输入样例
3
输出样例
10
5
16
8
4
2
1

解题思路

利用递归判断不为1是是奇数还是偶数 并进行相应操作

代码

#include <bits/stdc++.h>
#include<iostream>
#include <cmath>
#include <climits>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <deque>
#include <list>
#include <utility>
#include<cstring>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <iterator>
#define INT_MAX 0x7fffffff
#define INT_MIN 0x80000000
const int MOD = 1E9+7;
const int N = 100000+5;
using namespace std;

int f(int x)
{
    if(x!=1){
        if(x%2==0){
            cout << x/2 << endl;
            f(x/2);
        }
        else{
            cout << x*3+1 << endl;
            f(x*3+1);
        }
    }
}
int main()
{
    int n;
    cin >> n;
    f(n);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值