1128 N Queens Puzzle (20分)——C语言实现

1128 N Queens Puzzle (20分)

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1 ,Q2,⋯,QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

Figure 1
Figure 1
Figure 2
在这里插入图片描述

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format “N Q​1 Q​2 … Q​N”, where 4≤N≤1000 and it is guaranteed that 1≤Q​i ≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

题目大意:

我英语还是那么菜,题目意思我只能靠猜,然后用翻译软件翻译一下,现在正在计划努力学习中,哈哈哈。大概意思如下:判断给你的数据是否满足N皇后问题,即没有两个皇后共享相同的行、列、对角线;题目已经规定列不相同,所以只判断行和对角线就可以。

代码:

#include<stdio.h>
#include<math.h>
int queen[1010]={0};
int main(){
	int K,n;
	int t,i,j;
	int flag;
	scanf("%d",&K);
	for(t=0;t<K;t++){
		flag=1;
		scanf("%d",&n);
		for(i=0;i<n;i++){
			scanf("%d",&queen[i]);
			for(j=0;j<i;j++){
				if(queen[i]==queen[j] || fabs((float)(queen[i]-queen[j]))==fabs((float)(i-j))){
					flag=0;
					break;
				}
			}
		}
		if(flag==1)
		    printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值