1006 Sign In and Sign Out (25分)——C语言实现

1006 Sign In and Sign Out (25分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:

给定若干个记录,寻找最早登陆与最晚注销的人。

思路:

把时间换算成秒,若小于最早登陆时间mintime,则把该数值赋值给mintime,并记录名字;若大于最晚注销时间maxtime,则把数值赋值给maxtime,并记录名字。

代码:

#include<stdio.h>
#include<string.h>
#include<limits.h>
int main(){
	int M, i;
	int maxtime = INT_MIN, mintime = INT_MAX;
	char name[20];
	char signin[20], signout[20];
	scanf("%d", &M);
	for(i = 0; i < M; i++){
		getchar();
		scanf("%s", name);
		int h1, m1, s1, h2, m2, s2;
		scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
		int tempin = h1*3600 + m1*60 + s1;
		int tempout = h2*3600 + m2*60 + s2;
		if(tempin < mintime){
			mintime = tempin;
			strcpy(signin, name);
		}
		if(tempout > maxtime){
			maxtime = tempout;
			strcpy(signout, name);
		}
	}
	printf("%s %s", signin, signout);
	return 0;
}

学习(整形上下限):

C中常量INT_MAX和INT_MIN分别表示最大、最小整数,定义在头文件limits.h中。
因为int占4字节32位,根据二进制编码的规则,INT_MAX = 2^31-1,INT_MIN= -2^31。C/C++中,所有超过该限值的数,都会出现溢出,出现warning,但是并不会出现error。如果想表示的整数超过了该限值,可以使用长整型long long 占8字节64位。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值