【PAT甲级】1013 Battle Over Cities (25分)——C语言实现(DFS)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意:

给出n个城市之间有相互连接的m条道路,当删除一个城市和其连接的道路的时候(即最后一行的数字),问其他几个剩余的城市至少要添加多少个路线才能让它们重新变为连通图。

思路:

(连通分量数量 - 1)条线即可把各个连通分量连接到一起。所以此题为求连通分量个数,使用dfs遍历,visit[]数组标记。

代码:

#include<stdio.h>
int n;
int v[1010][1010];
void dfs(int i, int visit[]){
	visit[i] = 1;
	for(int j = 1; j <= n; j++){
		if(!visit[j] && v[i][j] == 1){
			dfs(j, visit);
		}
	}
}
int main(){
	int m, k, i;
	scanf("%d %d %d", &n, &m, &k);
	for(i = 0; i < m; i++){
		int a, b;
		scanf("%d %d", &a, &b);
		v[a][b] = v[b][a] = 1;
	}
	for(i = 0; i < k; i++){
		int a, count = 0;
		int visit[1010] = {0};
		scanf("%d", &a);
		visit[a] = 1;
		for(int j = 1; j <= n; j++){
			if(visit[j] == 0){
				dfs(j, visit);
				count++;
			}
		}
		printf("%d\n", count-1);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值